A plea to fix email setup in Sysadmin

Just setting up a new system and once again had a major headache getting email to work with an external email service (M365 in this case).

This has been an issue for years now…even with SysAdmin Pro and a correct setting in Voicemail admin, a new install wants to send emails using the from [email protected]

The only way I’ve found to fix this is by adding rewrite entries into /etc/postfix/generic

New this time was that the apparently critical line smtp_generic_maps = hash:/etc/postfix/generic was missing from /etc/postfix/main.cf

So the rewrite entries weren’t working until I found and fixed that.

This forum is full of posts about this going back years…many years. A couple:

Please, please if the powers that be can get this in queue for a fix?

1 Like

Been awhile since I looked at this but seems to me I was able to do something in voicemail admin settings. I believe it was the “From”: string that I was able to change. Sounds like you want to change the actual from username which is different. There is also the serveremail=vm@asterisk setting but I don’t remember what that changed. I don’t think either of those will do what you want though.

So there was a road map to abstract all email to framework. The plumbing was put in to 15 and in 16 we were going to unify and standardize email. That said the “WE” who had this roadmap had left the dev team before 16 was planned out. Much of the 16 focus went to migration from zendguard to ioncube so people could use php 7.4. The migration couldn’t happen until the commercial products could use it. I haven’t seen one word about the future of FreePBX unfortunately. The dev team has been generally reduced to the team in Bangalore. The Sangoma CEO was just unceremoniously ousted which as a shareholder I think was long over due. That said the Star2Star guy is in charge now and I wouldn’t be surprised if that portfolio of products gets more attention. There is going to be a big push to consolidate the countless redundancies in the product line and anything that makes money will get priority. In general we are in wait and see mode.

Currently the way email is setup in most places it does a check… if there is a from address in whatever place it wants it then use that, otherwise use user @ hostname which is why that is a common default.

Alas :frowning:

That’s in Voicemail Admin and I have it set correctly. No affect on the problem. The only way to make the system do as its been told there and in SysAdmin is the manual edits to those files I listed.

In postfix, simply rewrite everything to your email

@freepbx.sangoma.local [email protected]


That no longer works without the additional steps I detailed above.

My point is that if an advertised feature of SysAdmin Pro is “email configuration”, then that feature should work: Configure email on the FreePBX system so that it works/is functional.

It doesn’t. And it hasn’t since at least 2017…and likely has never worked.

Nothing will change it a support ticket wasn’t raised.

I have never opened a ticket that resulted in anything getting fixed. In over a decade. I don’t waste the time any longer; doing the same thing over and over and expecting a different outcome is insane.

I only have ever configured Postfix manually and ignored all email settings in Sysadmin. Works great for me.

Also, happy cake day @PitzKey

Unfortunately, I fully agree with you on this one and I wish that wasn’t the case.

Over the years we implemented our own scripts to setup postfix with our SMTP gateway, a script that replaces PagePro’s scheduled pages (we also wrote a small NodeJS library that makes exclusions very easy, such as holidays etc.) etc etc etc.

Thank you

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.