A gotcha when converting from asterisk 1.4 to 1.6

I had installed outcall and it worked fine. I could click on an outlook contact and dial one of their numbers. Worked fine. I converted to asterisk 1.6 a few weeks ago and noticed the outcall dialing was broken. When looking at the SIP trace, I saw that asterisk was sending back a “Permission denied” to outcall (which uses the AMI to place the call.) Turns out a new option in asterisk 1.6 was added to the AMI permissions, ‘originate’, which needs to be added to the read and write acls in manager.conf.


that is correct, the stock manager.conf file has that now and the AMI module should have that as an option.

I added migration code in 2.8 and even in 2.7 next time I push out a version bump (e.g. 2.7.1) but in the mean time it needs to be done manually.

This breaks callback which counts on the default manager settings. For outcall though, you probably want to create different credentials with the manager module where you can add these in.

I had originally taken the easy way out and just re-used the admin credentials. Thanks!