*97 access to shared voicemail without password?

voicemail
configuration
Tags: #<Tag:0x00007f70216465e8> #<Tag:0x00007f7021646430>

(James) #1

Attempting to set up 3 extensions with the same shared voicemail account. They do not have their own, individual mailboxes. I created the voicemail as ext. 100 and set the mailbox attribute on each extension too 100@default in order to get a working MWI.

I can access VM by diailing *98100 and entering the password, but ideally we’d like to have to not enter a password. Someone had posted this question back in April, and got an answer which looks like it may work, but I’m not sure where to enter the custom context. The topic is too old for me to reply and my account is too new that I can’t post a link, so pasting below. Any pointers?

you might try a custom context to match *97 based on caller ID number, something like:
[muh-customz]
exten => *97/101,1,VoiceMailMain(555@default,sa)
exten => *97/102,1,VoiceMailMain(555@default,sa)
exten => *97/103,1,VoiceMailMain(555@default,sa)

Bonus question: Setting the mailbox to 100@default works 100% of the time one one extension. On another, I’ll get a MWI immediately after a message is left, but it disappears after a minute or so. I did set up a BLF for *98100 which seems to be more reliable, but still curious why one extension is acting differently than another.


(Communication Technologies) #2

custom extensions can go in /etc/asterisk/extensions_custom.conf

You can build a reference in the GUI, once you have the code in place:
https://wiki.freepbx.org/display/FPG/Custom+Destinations+User+Guide#CustomDestinationsUserGuide-CreatingaCustomDestination

No sure on your second question. You’d have to look at the hints and see if it is changing when the light goes out. If the hint is still good, it is something with the extension/phone. If the hint changes then it is an issue on the server side. Not sure it is worth the effort if you have a viable solution, but I would be curious if you do find the answer.


(James) #3

OK, I’ve placed the config below in /etc/asterisk/extensions_custom.conf - the shared mailbox is 100 and I’d like to have *97 access from 110 and 111. After saving the file and restarting the server, I’m still being prompted for mailbox number when dialing *97. Anything else I am forgetting?

[shared-voicemail]
exten =&gt; *97/110,1,VoiceMailMain(100@default,sa)
exten =&gt; *97/111,1,VoiceMailMain(100@default,sa)

(Communication Technologies) #4

Yes, you have to configure a path to this context you just made. In other words, how does dialing *97 get to [shared-voicemail]?

You could have everything (*97) go to this context, with a line to send anything not 101/2/3 back to the normal voicemail context, or you could override the current voicemail context to include your context. I prefer option A, but no wrong way.


(James) #5

Thanks - that all makes sense. I think I now understand what needs to be done, but not quite sure how to configure it. I did check the help page for Custom Destinations but still unfamiliar with the terminology and what values/strings I need to enter.

I appreciate the help, but without just asking for the correct config, perhaps I shall just tell the users to press the Voicemail BLF and enter the password :smile: