*90 Feature not working (Call Forward Busy Activate)

Hi, I have problems with some feature code.
I would like to use Call Forward Busy Activate(*90), but it isn’t work.
I activated this code on one extension(600).
For activate I dial *90 and then extension number to which calls will forward.
I made test for check it.
But when extension 600 talked with some other extension, calls still come to 600.
Please, help me, what did I do wrong?

Thank you!

That’s troubling right there, since when extension 600 is busy, you should either follow the Call Forward Busy route (if activated) or go straight to the Voicemail Busy. If the phone is ringing while you’re on it, there’s something else going on that we need to know about.

You are right, but before activated I could receive call too, when my extension was busy I didn’t have any trouble with active Call Forward Busy, that mean it is activated.
Maybe, should I change some settings on my PBX?

Now you’ve got me confused. Isn’t Call Forward Busy there to forward calls when your phone is busy. I thought that was why we also have “Do Not Disturb - Busy” to send calls to the “Busy” Voicemail…

Sorry for my absurd answer. Our staff need to have enable pick up calls and we created ring group for it. Extensions 600 and 601 are in this group. We have 2 land line with same number. Now all inbound calls are going to 600. I would like to do something for call transfer to 601, when extension 600 is busy.

CF Busy will only work if your phone reports busy and the call doesn’t ring. If a call rings through to your phone, it is not busy. Try disabling call waiting.

I think @lgaetz Lorne has the hit it on the head. It sounds like your phone isn’t really “busy” because of (possibly) Call Waiting.

You’re tossing Ring Groups in here too, so I want to circle back just for a second.

I think I understand that you have two extensions in a ring group, but the first phone (ext 600) is the only one that ever rings, and even if someone is on 600, the phone still rings there.

The reason I ask is because you need to make sure the Ring Group is configured correctly for this to work, and the extensions need to be set up correctly for this to work. Rather than try to sift through the hundreds of possible setup options, you are going to need to give us more information than you currently are.

For example:

  • Are you actually using FreePBX? Which distribution and which version?
  • Have you captured the file /var/log/asterisk/full for when a call comes in and fails like this?
  • Have you considered using Pickup Groups instead of a ring group?
  • Have you got Call Waiting enabled?
  • What ring strategy are you using in your ring group?
  • Try describing, in detail, what it is you expect the system to do - we can make suggestions for this seemingly simple problem.

Yes, @lgaetz is right. Call Waiting was enable. My issue is fixed.
Thank you so much!

1 Like