7960/7940 Logo


#1

Hello there, I would like to try and put a custom logo on the phones… I have spent several hours googling and searching different forums only to waste time trying things that only gave me half the answers, and left me with more questions? Such as max pixel size, type of file and so on… so if there is any one out there that has been able to accomplish this with success and would like to share their process for doing this, or point me to factual documentation I would much appreciate it.

Specific questions are the pixel size, format of file, and can the file be placed somewhere on the asterisk box to load, or does it need to be hosted on an external web server?

Asterisk 1.8 FreePBX 2.9 Cisco phones with Sip firmware 3-08

Thanks in advance


Cisco 7960 - How to use custom logo without CallManager
#2

From Voip-info.org

Put your logo in /var/www/html


#3

Thanks, this is one I was looking at and didn’t seem to work for me though, what was confusing me is the logo_url: “http://www.mywebserver.com/asterisk/logo.bmp” I’m not sure what to put there to point to this since it is on the asterisk box?


#4

You will have to change the logo URL in your Cisco configuration.

Assuming you follow the steps above and you place your image file in /var/www/html of your PBX server, then this logo is served by the web server built in (the same you are using to go to the freepbx web pages).

You would change the configuration to:

logo_url: “http://192.168.1.5/logo.bmp”;

You need to change the IP address to match your PBX and the name of the image to however you have named the image (case sensitive).

To test, that the logo is in the right place, you can also just type the URL into any web browser and you should see the image.

You can also place the logo on any other web server and enter that URL.


#5

Thanks, I am making progress. I made a simple text image in Paint and saved as a .bmp. I can access the image via a browser… but the phone just display a blank screen… the pixel size is under the 90x56. I’m going to try a few other things yet. Any other suggestions?


#6

Got it working! Think the font I had used just couldn’t be displayed


#7

Cool…Glad you got it working


#8

When using End Point Manager from the FreePBX distro it has variables defined.

logo_url: “{$logo_url}”

There are also other variables like that, do you know how to figure out where those are looking?

Any idea where the logo would go on the FreePBX distro?


(Andrew Nagy) #9

Same place in the http directory and the logo_url is set in the template manager section of endpoint manager.


(Brendan) #10

hi, i am having a few difficulties of my own with the logo. I have the image format right, and the phone is displaying it however, it doesn’t centre it and it ends up tiled. so, what displays is about 20% cut off on the right, and that’s moved to the left.

my example was a simple image, specified to the exact size above with the test “LOGO TEST” … however, when it comes up on the phone as “GO TEST | LO” (the pipe represents a black line which is the edge of the image)…

different sizes just resize back to the tiled version. i’m not having much luck with google either.


(Brendan) #11

interestingly, if i shrink the size of the image, it doesn’t change the percentages of what’s tiled … so for my example, i still end up with GO TEST LO, except the entire thing is smaller rather than ending up with GO TEST LOG which is what I would expect, if it was actually tiling the image.


#12

Hello,

I have the same issue on my 7640, logo is tiled.

Did you get it working?

Thanks


(Brendan) #13

No … never did … as this was purely cosmetic, I gave up…


(Tom Rymes) #14

I have never seen the tiling problem on 79x0. The logo is displayed left-justified, it is not supposed to be centered.

You can try these URLs to see if they work for you (then save the files locally, I won’t be able to leave these up forever):

http://89concordst.com/asterisk.bmp
http://89concordst.com/asterisk-tux.bmp
http://89concordst.com/volvo-r.bmp

All three work fine on my phones, the last one should please any Volvo fans out there.

Just to confirm, you have an old 79x0 device, not one of the newer devices that use the XML configuration files, color screens, etc, right?

Tom


(Brendan) #15

Hi Tom,

Yes left-justified … does that change anything with the image itself? All I did for the image was follow the Cisco guidelines for format, colours etc etc … Simply got a company logo from our website, loaded it up in GIMP and made the required changes.

Also, I was using the old XML 7940’s … the ones that are like a decade old now haha (but still a pretty decent handset).

I’ve personally been retasked to a new project and as I said before, logo’s really aren’t imperative to a functional system… If i get a chance I will have a look at this today and reply back for the sake of anyone else who might be watching this thread.

Edit: Skyking above has quoted how I formatted my images, as per the write up at voip-info.


(Tom Rymes) #16

No, the fact that the logo appears in the left if the screen does not affect the image itself, I only mention it because someone above commented that it wasn’t centered, and I wanted to clarify that it shouldn’t be.

Try the images I linked to first, they are designed for the 7940/7960 like you describe.


(Totallytech) #17

sorry to bring back up an old thread, but I’ve got 7940 handsets in the office.

I added this code to the sipdefault.cnf file:

#The logo_url contains a URL to the logo BMP file
logo_url: "http://www.mydomain.com/phone/asterisk-tux.bmp"

however for some reason the phone ignores it. I get a blank display - I’ve downloaded and tried 4 or 5 that other people have confirmed worked on their handsets. Can you see anything wrong with the above code?

I’ve browsed online to http://www.mydomain.com/phone/asterisk-tux.bmp to make sure that its actually there and it is so I have no idea why the phone wont display any logos?

edit: ok, so I’ve changed my logo_url: to actually grab the one that I downloaded earlier… so its now:

logo_url: "http://www.loligo.com/asterisk/cisco/79xx/2003-04-27.examples/asterisk-tux.bmp"

and my phone displays it fine, however as soon as I change it back to http://www.mydomain.com/phone/asterisk-tux.bmp it refuses to display it - even though I downloaded the original one and uploaded it to my own domain… (just for testing)

I’ve tried setting the permissions to 777 & 644 plus I’ve uploaded it as binary and then ascii just to make sure its not that doing it…

What else could it be?


(Maxyca) #18

I have uploaded file to /var/www/html, but I see file contents, not a picture. But the jpg file opens well.
For the Cisco 7940 only the format BMP is needed.
As I understand it, the situation is in the Apache setting. Because I have uploaded the same file to my other server (NAS4FREE) and it works on Cisco, BMP file was read.
Any ideas?


(system) closed #19

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.