7777 problems --Solved--

Ok I have a problem I am using voicepluse for my SIP service I have 2 numbers one is for voice and the other for fax.
There was a problem on their end yesterday and I thought it was on my end and was changing things and now that everything is working right again, my 7777 does not work any more.
I know i can create an empty inbound route but then my fax stuff will not go to the fax machine, it worked just yesterday but I don’t know what I did, if anything to change it.

I can call just fine if I enter the real phone number but 7777 is not ringing the main phone anymore.
CLI dump follows

-- Executing [[email protected]:1] Goto("SIP/13-08cb6208", "from-pstn|s|1") in new stack
-- Goto (from-pstn,s,1)
-- Executing [[email protected]:1] NoOp("SIP/13-08cb6208", "No DID or CID Match") in new stack
-- Executing [[email protected]:2] Answer("SIP/13-08cb6208", "") in new stack
-- Executing [[email protected]:3] Wait("SIP/13-08cb6208", "2") in new stack
-- Executing [[email protected]:4] Playback("SIP/13-08cb6208", "ss-noservice") in new stack
-- <SIP/13-08cb6208> Playing 'ss-noservice' (language 'en')

TIA,
Eric

Do you have an inbound route for 7777?

No i do not have that inbound route I only have 2 inbound routes 1 for voice line and 1 for fax, I have only ever had these 2 and they have worked fine for months.
I did try creating a 7777 one and it still got the same problem. I set the callerID and DID to 7777 and it did nothing. Now I could have left them both blank but then as I said earlier my different lines will not rings in different places.

Edit:
when I have an empty inbound route 7777 will give me a CLI dump of

– Executing [[email protected]:1] Goto(“SIP/13-08caee30”, “from-pstn|s|1”) in new stack
– Goto (from-pstn,s,1)
– Executing [[email protected]:1] Set(“SIP/13-08caee30”, “__FROM_DID=s”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/13-08caee30”, “1 ?cidok”) in new stack
– Goto (from-pstn,s,4)
– Executing [[email protected]:4] NoOp(“SIP/13-08caee30”, “CallerID is “device” <13>”) in new stack
– Executing [[email protected]:5] Goto(“SIP/13-08caee30”, “from-did-direct|12|1”) in new stack
– Goto (from-did-direct,12,1)
– Executing [[email protected]:1] Macro(“SIP/13-08caee30”, “exten-vm|12|12”) in new stack
– Executing [[email protected]:1] Macro(“SIP/13-08caee30”, “user-callerid”) in new stack
– Executing [[email protected]:1] NoOp(“SIP/13-08caee30”, “user-callerid: device 13”) in new stack
– Executing [[email protected]:2] Set(“SIP/13-08caee30”, “AMPUSER=13”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/13-08caee30”, “0?report”) in new stack
– Executing [[email protected]:4] ExecIf(“SIP/13-08caee30”, “1|Set|REALCALLERIDNUM=13”) in new stack
– Executing [[email protected]:5] NoOp(“SIP/13-08caee30”, “REALCALLERIDNUM is 13”) in new stack
– Executing [[email protected]:6] Set(“SIP/13-08caee30”, “AMPUSER=13”) in new stack
– Executing [[email protected]:7] Set(“SIP/13-08caee30”, “AMPUSERCIDNAME=Eric”) in new stack
– Executing [[email protected]:8] GotoIf(“SIP/13-08caee30”, “0?report”) in new stack
– Executing [[email protected]:9] Set(“SIP/13-08caee30”, “AMPUSERCID=13”) in new stack
– Executing [[email protected]:10] Set(“SIP/13-08caee30”, “CALLERID(all)=“Eric” <13>”) in new stack
– Executing [[email protected]:11] Set(“SIP/13-08caee30”, “REALCALLERIDNUM=13”) in new stack
– Executing [[email protected]:12] ExecIf(“SIP/13-08caee30”, “0|Set|CHANNEL(language)=”) in new stack
– Executing [[email protected]:13] NoOp(“SIP/13-08caee30”, “TTL: ARG1: 12”) in new stack
– Executing [[email protected]:14] GotoIf(“SIP/13-08caee30”, “0?continue”) in new stack
– Executing [[email protected]:15] Set(“SIP/13-08caee30”, “__TTL=64”) in new stack
– Executing [[email protected]:16] GotoIf(“SIP/13-08caee30”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,23)
– Executing [[email protected]:23] NoOp(“SIP/13-08caee30”, “Using CallerID “Eric” <13>”) in new stack
– Executing [[email protected]:2] Set(“SIP/13-08caee30”, “FROMCONTEXT=exten-vm”) in new stack
– Executing [[email protected]:3] Set(“SIP/13-08caee30”, “VMBOX=12”) in new stack
– Executing [[email protected]:4] Set(“SIP/13-08caee30”, “EXTTOCALL=12”) in new stack
– Executing [[email protected]:5] Set(“SIP/13-08caee30”, “CFUEXT=”) in new stack
– Executing [[email protected]:6] Set(“SIP/13-08caee30”, “CFBEXT=”) in new stack
– Executing [[email protected]:7] Set(“SIP/13-08caee30”, “RT=45”) in new stack
– Executing [[email protected]:8] Macro(“SIP/13-08caee30”, “record-enable|12|IN”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/13-08caee30”, “0?2:4”) in new stack
– Goto (macro-record-enable,s,4)
– Executing [[email protected]:4] AGI(“SIP/13-08caee30”, “recordingcheck|20080605-084147|1212673307.72”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20080605-084147|1212673307.72: Inbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing [[email protected]:5] NoOp(“SIP/13-08caee30”, “No recording needed”) in new stack
– Executing [[email protected]:9] Macro(“SIP/13-08caee30”, “dial|45|tTr|12”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/13-08caee30”, “1?dial”) in new stack
– Goto (macro-dial,s,3)
– Executing [[email protected]:3] AGI(“SIP/13-08caee30”, “dialparties.agi”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
dialparties.agi: Starting New Dialparties.agi
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
dialparties.agi: Caller ID name is ‘Eric’ number is '13’
dialparties.agi: Methodology of ring is ‘none’
– dialparties.agi: Added extension 12 to extension map
– dialparties.agi: Extension 12 cf is disabled
– dialparties.agi: Extension 12 do not disturb is disabled
– dialparties.agi: dbset CALLTRACE/12 to 13
– dialparties.agi: Filtered ARG3: 12
== Manager ‘admin’ logged off from 127.0.0.1
– AGI Script dialparties.agi completed, returning 0
– Executing [[email protected]:7] Dial(“SIP/13-08caee30”, “SIP/12|45|tTr”) in new stack
– Called 12
– SIP/12-08ce3c00 is ringing
== Spawn extension (macro-dial, s, 7) exited non-zero on ‘SIP/13-08caee30’ in macro ‘dial’
== Spawn extension (macro-dial, s, 7) exited non-zero on ‘SIP/13-08caee30’ in macro ‘exten-vm’
== Spawn extension (macro-dial, s, 7) exited non-zero on ‘SIP/13-08caee30’
– Executing [[email protected]:1] Macro(“SIP/13-08caee30”, “hangupcall”) in new stack
– Executing [[email protected]:1] ResetCDR(“SIP/13-08caee30”, “w”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/13-08caee30”, “”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/13-08caee30”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,6)
– Executing [[email protected]:6] GotoIf(“SIP/13-08caee30”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] GotoIf(“SIP/13-08caee30”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,11)
– Executing [[email protected]:11] Hangup(“SIP/13-08caee30”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘SIP/13-08caee30’ in macro ‘hangupcall’
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘SIP/13-08caee30’

Looking at this and comparing it to the non working mode it looks like this line is the magic one

-- Executing [[email protected]:5] Goto("SIP/13-08caee30", "from-did-direct|12|1") in new stack

This is not happening without the empty route. I don’t know what that tells us but I hope others understand it.

Are you using a Zaptel type card? if so, in /etc/zapata-channels.conf (if you used genzaptelconf when setting up) or zapata.conf, you should have a context for your zaptel channel… by default it says from-pstn, which is how the 7777 feature code works, but if you change it to “from-zaptel” like what a lot of people need to do it breaks the 7777 tool.

Thanks for the help but I don’t have a zap card the system is pure voip, that is why I am confused when I get a “from-pstn”.
Just an FYI this is a up to date TrixBox system

"-- Executing [[email protected]:1] NoOp(“SIP/13-08cb6208”, “No DID or CID Match”) in new stack"
looks like the call doesn’t know where to go… try setting up an inbound route and leaving it completely blank as for the did, cid, settings etc… this should give you the “Any cid/did” inbound route which I believe is what you need for this feature to work.

Also, why is your fax on a separate inbound route? Different phone number for it? Either way I don’t see what’s stopping you from setting up any/any settings on your inbound route.

I have setup a catch all inbound route and all the calls go to the catch all extension. is a way to prioritize the inbound routes, so it goes through the real numbers and then to the catch all?
I will try setting 1 inbound route to catch all and placing the DID’s in the extensions.

That did it I now only have 1 in bound route
And the specific lines I needed to go places are specified in the extension themselves.
Thanks for the help.

voicepulse service seems pretty solid I have had them for a few years. I didnt think they had any problems earlier this week.

KM