*555 to mobile number

Hi all,

I am in a bit confusing situation that is my team wants me to make something like that if for example their extension is 555 when they dial it with *555 the call route to their mobile number.

Is this possible?

Please need your suggestions.


You could set up a misc application and misc destination to do this. Using your example see below

1: Build a Misc Destination and put their cell number in the Dial: section.
2: Build a Misc Application with the feature code *555 and set the Destination to your Misc Destination set above.

This way when they dial *555 it routes to the Misc Destination and dials their cell number.

Make sense?

Hi Jadams,

thanks for the help.

can you please give little example of this.

Jadam thanks and really appreciate your help in this regard. It works for me.

You’re welcome. Glad to help :slight_smile:

1 Like

That’s really nice of you :slight_smile:


Is there anything like #1 or #2 or #“any digit” when dialed and call will be routed to any destination or Number.


This way when they dial *555 it routes to the Misc Destination and dials their cell number.

Note that, by default, that is already how you direct dial their email, so by adding this, you invalidate the direct-to-email functionality.

hi cynjut,

what do you mean by direct-to-email functionality.

If you have any other solution of this please share.


If your extension is “555”, your direct voice-mail extension is “*555”. Instead of ringing your phone, it sends the call straight to your voicemail.

Now, that’s just the default. If you don’t mind losing this functionality, then the *555 thing to call a cell phone works perfectly well. A different way to handle it would be to establish a code that sends the call to their cell phone (like *9, for example).

A better solution would be to tell people to set their DND or CF to their cell phone and let them manage it through UCP.

Another way would be to set up an extension just for their cell phone - you can do that simply enough.

Another way would be to tell them it’s only 10 digits - just dial it.

In a corporate setting, there are issues with these kinds of dial rules. For example, if you get a voicemail on your personal phone, is it yours, or your employers? What about the call? Shouldn’t your employer have the right to be able to archive the voicemails that come in to support their business and control how their employees are contacted? What happens when you need to call someone back? The conversation is then over the cell phone network and completely cuts the employer out of the conversation, even though the call is about their business. Does your boss really want your cell phone associated with his business? What happens when you leave? Do you take the client with you? Do you have any responsibility for harming the business? Do you really want people to be able to call your cell phone directly? What about when you are on vacation? Should they call your office number, or straight to your personal cell?

These are all issues (and it isn’t a comprehensive list by any stretch of the imagination) when dealing with extending the office telephone system outside of the network.

All valid points. There are various ways to do this. Went off his example information but you have a great point.

1 Like

yeah I checked that it will directly lead to voicemail. but the thing is I have to set this thing only for few extensions in which only 1 extension exist and the remaining ones only exist in Misc Destinations.
If you have another example of this please share it with me.

really thanks.

hey Jadams,

I am facing an issue with this.

I have set *1004 as Misc Application and when I dial the feature code *1004 it route the call to the number in Misc Destination which is my cell number, but same I did with other extension *777 as Misc Application and when I dial *777 it will direct the call to voicemail not routing the call to Mobile number.

Need quick help on this.


Just out of curiosity change *777 to #777 and see if it routes.

Jadams, it works now with #777. what’s this. why it is working *1004 and not working with my other extensions.

Check your feature codes to see if there are any conflicts. also keep in mind like was stated above *(ext number) is direct to voicemail as well. Perhaps switching to #(extension number) will be your best route.

hi jadam,

Please check this with *777

– Executing [*777@from-internal:1] NoOp(“SIP/1004-000086f9”, “Transfering to Voicemail BOX 777”) in new stack
– Executing [*777@from-internal:2] VoiceMail(“SIP/1004-000086f9”, “777@default,su”) in new stack

and now see the other call with *1004

– Executing [*1004@from-internal:1] NoOp(“SIP/1004-00008717”, “Running miscapp 1: Faisal Mobile Testing”) in new stack
– Executing [*1004@from-internal:2] Macro(“SIP/1004-00008717”, “user-callerid,”) in new stack

and after that it will dial the misc destination properly and route the call.

hi Jadam,

I checked there is no conflict with feature codes. They are the unique ones.

I think settings stuck, I also give amportal chown and amportal reload commands to reload from the shell but nothing happened.

I would honestly just recommend switching to #(ExtensionNumber) (i.e. #777) or (ExtensionNumber)* (i.,e. 777*) is worth a shot as well. It’s conflicting with the voicemail system.

ok jadams thanks let me check with these now :slight_smile: