500 Internal Server Error on WebRTC call attempt

Hello guys,

Can someone help with the below, I’m getting 500 Internal server error on WebRTC call attempts.
I’ve installed the Doubango repository and host it on the FreePBX’s embedded HTTP server, extensions are able to log in, however, when I try to call another extension internally I get SIP 500.
Please find the screenshot below as I cannot upload files except 1 screenshot at a time.

Please provide the corresponding logs from FreePBX, as text, not images, using pastebin.freepbx.org.

Here it is https://pastebin.freepbx.org/view/89b8ffa7

/var/log/asterisk/full

No logs for the call attempts from the WebRTC appear in /var/log/asterisk/full, however, I’ve registered another extension with Zoiper, tested a call from the Zoiper ext 50003 towards the WebRTC extension 50001 and the call worked and appears in the log.
Please find the logs for it with SIP log as well, maybe you can check the difference in the SIP logs.
https://pastebin.freepbx.org/view/e1ed5def

If nothing appears in the full log, but the responses show FreePBX as the user agent, I’d have to assume some sort of man in the middle attack. At the logging level that FreePBX uses, I’d expect a 500 response to always produce a message in the logs explaining why it was being generated.

The issue was that on the “WebRTC” extensions I’ve had configured ws,wss,udp for transport, when I’ve left only wss it worked just fine.