411 Dial by first or last name

First off, I’m pretty new with FreePBX or Asterisk so please bare with me.

Our company is using FreePBX 12 and doing some testing with 411 to dial by first or last name. Our names are entered “First Last” and if we enter first 3 letters of the person’s first name, it finds the user but if we dial by last name, it returns no entries found.

Question i have is 411 using the Directory module? I even tried to remove the existing main directory and 411 still finds the user by first name without the directory even being there.

Is the phonebook the same as the directory? When dialing 411 is says “Welcome to the phonebook”.

I would really like to get the dial by first or last name working so any help would really be appreciated.

Please let me know if you need more information. Thank you.

I discovered that by default feature code 411 takes you to the phonebook and not the directory which are apparently different.

Here is what we had to do to redirect 411 to the directory:

  1. We disabled the feature code 411 which takes us to the phonebook
  2. Next we created a misc. application with feature code 411 and set the destination the directory that we created under module -> directory
  3. Test and make sure 411 takes you to your directory and you can dial by both first and last name.

That solved our problem.


Im a kind of lost with this freepbx…

Look i had a client that had elastix 2.4 and he was asking to upgrade to 2.5… so i did it…

But then the client told me that he had an IVR that tells you if you want to enter the name or last name of a person from the directory press #… and then he dial the 3 first letters from either that name or last name and the system matches the 3 letters and reproduce the name of the person which was recorded from every user of the extensions…

He told me that he used to do it with the misc destination… but i have no clue on how to make it work.

can someone pleaseeee help me with this…


Take a look at the directory module.

You will have to clear up our knowledge of your system, are you still using elastix as you stated ?


Yes im still using elastix 2.5 with a freepbx 2.10

Long past end of life. Upgrade to a supported system: