3starsnet - no incoming calls

Hi,
I’m new to freepbx and trying to set ip up to work in incoming and outgoing but it doesn’t seems to work.
My distro is the latest (2.11) and every module installed i sup to date. I’m using Firefox as browser.
the outgoing calls are working just fine but the incoming don’t.

the logs are giving this :

pbx.c: – Executing [[email protected]:1] NoOp(“SIP/028805607-00000000”, “No DID or CID Match”) in new stack
[DATE] VERBOSE[2951][C-00000002] pbx.c: – Executing [[email protected]:2] Answer(“SIP/028805607-00000000”, “”) in new stack
[DATE] VERBOSE[2951][C-00000002] pbx.c: – Executing [[email protected]:3] Wait(“SIP/028805607-00000000”, “2”) in new stack
[DATE] WARNING[2951][C-00000002] dsp.c: Inband DTMF is not supported on codec g722. Use RFC2833
[DATE] VERBOSE[2951][C-00000002] pbx.c: – Executing [[email protected]:4] Playback(“SIP/028805607-00000000”, “ss-noservice”) in new stack
[DATE] VERBOSE[2951][C-00000002] file.c: – <SIP/028805607-00000000> Playing ‘ss-noservice.gsm’ (language ‘fr’)
[DATE] VERBOSE[2951][C-00000002] pbx.c: – Executing [[email protected]:5] SayAlpha(“SIP/028805607-00000000”, “”) in new stack
[DATE] VERBOSE[2951][C-00000002] pbx.c: – Executing [[email protected]:6] Hangup(“SIP/028805607-00000000”, “”) in new stack
[DATE] VERBOSE[2951][C-00000002] pbx.c: == Spawn extension (from-trunk, s, 6) exited non-zero on ‘SIP/028805607-00000000’
[DATE] VERBOSE[2951][C-00000002] pbx.c: – Executing [[email protected]:1] Macro(“SIP/028805607-00000000”, “hangupcall,”) in new stack
[DATE] VERBOSE[2951][C-00000002] pbx.c: – Executing [[email protected]:1] GotoIf(“SIP/028805607-00000000”, “1?theend”) in new stack
[DATE] VERBOSE[2951][C-00000002] pbx.c: – Goto (macro-hangupcall,s,3)
[DATE] VERBOSE[2951][C-00000002] pbx.c: – Executing [[email protected]:3] ExecIf(“SIP/028805607-00000000”, “0?Set(CDR(recordingfile)=)”) in new stack
[DATE] VERBOSE[2951][C-00000002] pbx.c: – Executing [[email protected]:4] Hangup(“SIP/028805607-00000000”, “”) in new stack
[DATE] VERBOSE[2951][C-00000002] app_macro.c: == Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/028805607-00000000’ in macro ‘hangupcall’
[DATE] VERBOSE[2951][C-00000002] pbx.c: == Spawn extension (from-trunk, h, 1) exited non-zero on ‘SIP/028805607-00000000’

My trunk info is the following :
Peer Details
username=028805607
secret=MyDearSecret
type=peer
qualify=yes
language=fr
host=voip.3starsnet.com
fromuser=028805607
fromdomain=voip.3starsnet.com
dtmfmode=inband
nat=yes

Incoming Calls
User context : 028805607
User details :
host=188.66.8.27&voip.3starsnet.com
secret=MyDearSecret
type=peer
qualify=yes
language=fr
context=from-trunk
insecure=invite
nat=yes
dtmfmode=inband

Inbound route :
Description : 028805607
DID Number : +3228805607 (tried 003228805607 and 028805607 with no luck
Destination : ring groups 70400
other settings default

I tried the ring groups locally and it works
When I try to reach my number I’ve got a message “the number you have dialed is not in service”

I realy don’t understand why it doesn’t work…
Could you help me please ?

Thanks forward for your much needed help :slight_smile:

Best regards

Laurent

I’m new in freepbx too, but if you leave the DiD and CID empty it will work.

After it works you can test again. See http://www.freepbx.org/support/documentation/howtos/how-to-get-the-did-of-a-sip-trunk-when-the-provider-doesnt-send-it-and-

Thanks for your help rotan
After deleting the DID number, it worked
I then tried to analyse the logs and find the DID number but it still didn’t work (again). I then modified my registration string with /3228805607 at the end of the string and modified the DID to match and… it worked :slight_smile:
I’ll now resume my research to understand the beast better starting with digium codec and the message "Extension Routes is not registered.

Best regards
Laurent