FreePBX | Register | Issues | Wiki | Portal | Support

2x A400 is causing server to be unusable

asterisk
freepbx
configuration
Tags: #<Tag:0x00007fafc73ed658> #<Tag:0x00007fafc73ed158> #<Tag:0x00007fafc73ece10>

(Eyzi) #1

I have built a FreePBX server (the latest SNG7 build) with two 24-port A400 ports card. 48-port in total, but two main boards and two daughterboards. I had to do this due to PCIe space of the motherboard. There’s only one x16 PCIe in the middle which I needed for another card. The problem I’m having is that this setup is causing the server to spam the following message on the cli that freezes everything else and it’s basically unusable until I restart:

I couldn’t figure out why this is happening. I’ve reinstalled the OS about four or five times already but the same result. Though, when only one 24-port A400 is connected (a main board and a daughter board), everything works fine. When I disconnect this and connect the other 24-port A400 onto its respective PCIe port, everything works fine as well. It’s really when both 24-port A400s are connected that this issue occurs.

I couldn’t find anything that fixes this issue, or anything similar to this either. Any ideas?


#2

It is probably a matter of IRQ configuration. Just to check, what happens if you set one of the cards on the pciex16? Does it show the same errors?


(Eyzi) #3

Hi, thanks for the reply. Just tested this and I got the same error.


#4

Just for the sake of testing, can you try installing FreePBX 13 and see if the error still persists?


(Eyzi) #5

I tried installing 10.13.66 and it doesn’t look like I can even install it (choosing FreePBX 13 + Asterisk 13, both vanilla and advanced).

There’s also an issue that made the RAID controller not appear during POST making the SSDs not appear in the BIOS anymore. This started occurring around the 3rd or 4th reinstall of FreePBX 14 but it was fixed after a reboot. Now it shows around nine times out of ten boot ups and I usually have to clear the cmos and reconfigure BIOS to make it appear.


#6

It seems that FreePBX 13 is throwing a kernel panic. It might be possible that your motherboard is not suitable for two cards. Remember that analog cards generate a good amount of interrupts and it might be possible that your particular motherboard can’t handle it.


(Eyzi) #7

That’s good if that’s the case. I was also thinking it’s the fact that there are two main boards that’s causing the problem but I didn’t want to order anything only to find out that there’s an easier fix. So if I go order another daughter board and a 4-card backplate and just have it one 48-port card, would that potentially fix the interrupt issue?


#8

I would first check those same cards together on another motherboard, just to make sure they are not malfunctioning. Not sure about the return policy on those cards, but if you are still allowed to return them, and you need a quick solution, you could just return one of them and get a daughtercard.
You could also contact Sangoma, I assume that those cards have some kind of support if they are brand new.


(Eyzi) #9

Alright. I’ll do that. Thanks so much for your help!