2nd line won't register (FreePBX 16)

I had my 1st Freephoneline account registered successfully with pjsip, but for the 2nd account from the same provider, I duplicated the trunk and just modified the credential, it won’t register. On the Asterisk Info page it shows ONLINE, but on the provider’s status page it shows disconnected. I can make calls on the 2nd line but no incoming calls, it went to voice mail directly. On the Registries page it only shows the 1st line registered.

Any help would be appreciated.

That will likely be because your options are checking fine but not the ones from the provider. Check on sngrep if you are seeing options from that ‘second’ trunk.

Update: was from the phone and the dictionary uppercase’d it.

Just so ‘newbies’ understand, linux is ‘case sensitive’, when posting, please everyone please say exactly what you mean i.e. sngrep not SNGREP because the first format works but not the second.

Are you sure they are not simply confused by having two different accounts trying to register from the same IP address and port?

First, check that FreePBX isn’t messing up:
At the Asterisk command prompt, type
pjsip set logger on
wait until both lines have attempted to register and look at the Asterisk log. Confirm that REGISTER requests for both lines are present and proper, then look at the response to the second line registration – it may give a clue as to what’s wrong. If you have trouble deciphering it, paste the relevant section of the log at pastebin.freepbx.org and post the link here.

If the provider does not support multiple registrations from the same port, putting one trunk on pjsip and the other on chan_sip could be a workaround. Or, you can set up two pjsip transports, though that requires manually editing the config files.

Possibly, they don’t support multiple registrations from the same IP address, in which case you are out of luck, unless you have access to a second IPv4 address.

Nope. I’m actually migrating from freePBX 13 to 16. On 13 I had 4 lines with the same provider no problem, the only difference is chan-sip vs pjsip

Log with SIP trace, please.

Found a solution here but it won’t allow me to post link.
Problem solved
Thank you all

Please let us know how you solved it, so future readers who find this thread can benefit. For example, put the link between backquotes
which will display in the forum as
or replace the last . in the URL with %2E

either of which can be pasted into a browser address bar, etc.
Or, just post the change(s) you needed to make.

The contact url needs to have sip: in front of it.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.