2 beeps heard at voicemail prompts to leave message [SOLVED]


(Hey Brodes) #1

Hello,
I am using Asterisk Version: 16.13.0. This is happening on internal and external calls.

When you reach the voicemail of any extension you are meant to hear:
“Please leave your message after the tone, when done hang up or press the hash key” Beep.

What is actually happening is that you hear:
“Please leave your message after the tone, when done hang up or press the hash key” Beep. BEEP.

That is two beeps and the second beep is louder than the first.

I have checked the sound files too and they are OK. Just a single beep.
I have disabled VM and re enabled it too.
Anyone got any ideas??


#2

How about a log?


(Hey Brodes) #3

This is the log from when the VM message starts until the time of hangup.

10593[2021-07-03 11:29:36] VERBOSE[30057][C-00000025] pbx_builtins.c: Goto (macro-get-vmcontext,s,300)

10594[2021-07-03 11:29:36] VERBOSE[30057][C-00000025] pbx.c: Executing [s@macro-get-vmcontext:300] NoOp(“SIP/701-0000002e”, “”) in new stack

10595[2021-07-03 11:29:36] VERBOSE[30057][C-00000025] pbx.c: Executing [s-NOANSWER@macro-vm:2] VoiceMail(“SIP/701-0000002e”, “850@default,u”) in new stack

10596[2021-07-03 11:29:36] VERBOSE[30057][C-00000025] file.c: <SIP/701-0000002e> Playing ‘/var/spool/asterisk/voicemail/default/850/unavail.slin’ (language ‘en_AU’)

10597[2021-07-03 11:29:36] VERBOSE[30057][C-00000025] file.c: <SIP/701-0000002e> Playing ‘/var/spool/asterisk/voicemail/default/850/unavail.slin’ (language ‘en_AU’)

10598[2021-07-03 11:29:37] VERBOSE[30057][C-00000025] file.c: <SIP/701-0000002e> Playing ‘vm-intro.ulaw’ (language ‘en_AU’)

10599[2021-07-03 11:29:43] VERBOSE[30057][C-00000025] file.c: <SIP/701-0000002e> Playing ‘beep.ulaw’ (language ‘en_AU’)

10600[2021-07-03 11:29:43] VERBOSE[30057][C-00000025] app_voicemail.c: Recording the message

10601[2021-07-03 11:29:43] VERBOSE[30057][C-00000025] app.c: x=0, open writing: /var/spool/asterisk/voicemail/default/850/tmp/Cv4ka1 format: wav, 0x6af71f18

10602[2021-07-03 11:29:44] VERBOSE[30057][C-00000025] app.c: User hung up

I can see item 10596 and 10597 are duplucates. I don’t hear two greeting just two beeps.

Thanks Dicko for your speedy response.

Mike.


(Hey Brodes) #4

Further to this I have tried all english other languages and this issue is only happening on the english Australia setting.


(Hey Brodes) #5

I found the issue. The log shows…

6084[2021-07-03 17:34:16] VERBOSE[18078][C-00000049] file.c: <SIP/850-0000005a> Playing ‘vm-intro.ulaw’ (language ‘en_AU’)

6085[2021-07-03 17:34:22] VERBOSE[18078][C-00000049] file.c: <SIP/850-0000005a> Playing ‘beep.ulaw’ (language ‘en_AU’)

So first the intro is played and then the beep. So what is happening is that there is a beep in the intro recording (1st beep) and then the actual beep prompt is then played. Hence hearing 2 beeps.

All I did was rename the intro file so it wouldn’t load and the default intro is played instead. If others experience this you can also swap out the intro file for one of the other english language file.

Cheers.

Brodes.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.