2.9 Bug or brain dead?

No matter what technology trunk I use (SIP or IAX2) the details are not saved.

The peer is created in iax_additional or sip_additional however no options are written out.

The text box in the web page where you enter peer details is also blanked when you click save.

Did I find a bug or an installation issue?

I checked permissions on all files and links in /etc/asterisk

don’t really know what you mean by details are not saved.

If you mean like all the settings, they should be, I’ve created extensions testing on fresh systems (thus having to create vs. migrating) and they worked fine…

Thanks Philippe…

This is a fresh system and this is on trunks…Anything you enter in Peer Details or User Details is erased when you hit save at the bottom of the trunk

What gets written to sip or iax_additional.conf is this:


that’s the correct peer name and context…the stuff after from-trunk is not in the config I entered.

To make it clear data is not retained in either the user/peer details.

More useful data, this is all that is written to the databases:

mysql> select * from iax;
| id        | keyword | data    | flags |
| tr-peer-2 | account | MAI-CLE |     2 |
1 row in set (0.00 sec)

mysql> select * from sip where data = 'POTS';
| id        | keyword | data | flags |
| tr-peer-3 | account | POTS |     2 |
1 row in set (0.00 sec)

In this example POTS is a SIP trunk and MAI-CLE is an IAX.


k, thanks, was a bug, just added it yesterday, sorry :frowning:

fixed now, #4880


Just checked out the fix, the Peer details are appearing but not the user details.


I just created a SIP trunk, with both peer and user settings, it worked as it should.

I can also confirm with a new SIP trunks, both peer and user details, and after editing they continue to be there with the changes.

Thanks, will test tonight!

Sorry guys. Don’t know what I was thinking, I had not filled in a user context so it was dropping the user details. I confirm it is working as it should.