2.7 Beta problem with change in inbound routes - no email address

I really like the improvements in 2.7 for faxing. One thing that we’ve been doing with fax is now broken, however. Essentially we were doing this:

  1. Create a custom dialplan to handle an inbound fax. This allows us to customize the rxfax properties and other features. Some of these are now handled in the fax module such as setting minimum and maximum speeds…but we still need some features of this custom dialplan.
  2. Set up the custom dialplan as a “Custom Destination” in FreePBX.
  3. Set up an inbound route with an email address for the inbound fax line but disable fax detection. The custom dialplan uses the email address set by the inbound route to send the fax to that email address within the custom dialplan we created.

Now that the Inbound Route no longer has the email address associated with it there is no way to achieve this type of customization. We would now have to put the email address in the custom dialplan which is problematic.

Is there a way to associate an email address with an inbound route? Wouldn’t this still make sense to do since the fax detection can be configured on the Inbound Route?

The initial decision has been to remove that option once you have migrated away since we may obsolete it in the future. With that said though we wanted to hear feedback like you have provided here. The ability is still there, if you were to go into the database and manually populate the email address field in the fax table that option would show back up.

I would suggest you file a ticket outlining what you need to do (similar to what you did here). This will allow the dev team to consider it in context of how things changed and determine what options there may be to achieve what you are trying to do. (One of them might just be an amportal.conf settings that forces the email address field to always be in the inbound route, as it is for a any inbound route that was migrated).

Perfect, I’ll create the ticket as a feature request. Thanks!

Can you tell me the amportal.conf method of forcing it to show up so we can continue testing a new install of 2.7?


there is no way to force it right now, it is one thought on how we might address it…

OK, sorry about that. I mis-understood.