16 framework module bug


(Simon Telephonics) #1

There was a bug released into framework 16.0.10.24 which then prevents module updates from working.

What’s the best way to recover? You can’t use the fwconsole ma download/install/upgrade or the Module Admin in the GUI.


(Kapil Gupta) #2

Hi @billsimon fyi - 2021-09-17 Security fixes release update


(Simon Telephonics) #3

Thanks.

How do you release a bug like that into stable (even in a beta version) when it breaks core functionality? PHP 7.4 is the required version for FreePBX 16…


(TheJames) #4

:zipper_mouth_face: we both know


(Simon Telephonics) #5

I’m just complaining. :wink:


(Lorne Gaetz) #6

Fair question

From my understanding, this 16 Framework bug was only just exposed by the recent published security fixes. Normal module admin upgrades had been working as expected and were not affected. Once modules tagged as security update showed up in the repo, the bug was identified and a fix published asap. As it’s framework, the fix must be applied before module updates resume working again.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.