10.13.66-64bit ISO

Hi Guys,

I have been trying to deploy this ISO on a new server, but it fails whether or not I setup RAID via iDRAC (Motherboard) or FreePBX sets up its own SW RAID1.

When I choose “No RAID”, it doesn’t seem to detect the virtual disk created by iDRAC and creates 2x 500 GB Virtual Disks which in turn causes the server not to boot… Out of curiosity, I tried doing a normal install and get the following error:

Tried in Disable, RAID, ACHI, and ATA Mode - nothing works.

Try an older iso. If it works then just allow the updater scripts to run and then you’ll eventually be on the latest version.


Thanks for the tip, unfortunately same result (Full Install, No RAID, Advance)…



Even updated BIOS and a few other drivers. :frowning: Getting the error above when doing the normal “Full Install” and no booting if done via “No RAID”. I’ve done dozens of installs on Supermicro hardware successfully, this is the first one I’ve tried on a Dell and the experience is a bit surprising.

If you use Dell’s iDrac then your disks e=will show up as something like

cat /proc/partitions
major minor #blocks name


104 0 976729816 cciss/c0d0
104 1 1007 cciss/c0d0p1
104 2 976720583 cciss/c0d0p2
104 9 8192 cciss/c0d0p9
104 16 976729816 cciss/c0d1
104 17 1007 cciss/c0d1p1
104 18 976720583 cciss/c0d1p2
104 25 8192 cciss/c0d1p9
104 32 2147450879 cciss/c0d2
104 48 2147450879 cciss/c0d3
104 64 2147450879 cciss/c0d4
104 80 2147450879 cciss/c0d5

(This for a machine with a few harddrives but using ZFS raid1 and not the hardware raid.)

I suggest you reset your raids on boot to be individual raid0 drives, and use the “advanced” method bearing in mind the appropriate /dev/cciss/c* names of the devices. as the components of your raid(s)

I’ve tried with and without iDRAC configuring the RAID and still the same issue. Either no booting or I can’t proceed with the installation. I was able to install CentOS without any issues simply to test the hardware for any driver issues…

This is what I am getting if I let FreePBX configure using “Full Install”.

Sorry I can’t help iDrac raid would not expose /dev/sdc that is probably your installation media , I will defer to the Sangoma guys as to why their install doesn’t see you iDrac partitions.

Try using the Sangoma 7 distro instead

Hi Andrew,

I’ll give the beta a try in the morning (currently 12 AM here). Hopefully it works…

/dev/cciss/* is HP’s ‘Smart Array’ stuff (which is supported in SNG7, and not supported in RHEL7).

I’ve sent @gcm a private message with the prerelease 1703 ISO to test.


I received your PM, it worked well. But, unfortunately the installation hung on this step for over an hour so I gave up…

Instead of formatting the 2 HD’s via iDRAC, I ended up doing this in a CentOS Live CD:

dd if=/dev/zero of=/dev/sda bs=512 seek=$(( $(blockdev --getsz /dev/sda) - 1024 )) count=1024
dd if=/dev/zero of=/dev/sdb bs=512 seek=$(( $(blockdev --getsz /dev/sdb) - 1024 )) count=1024

Finally got 10.13.66-64bit to work after that. A bit strange, but whatever. Glad this is solved after hours of trying.

1 Like

The FreePBX install can take some time. It downloads, compiles, and installs, a pile of NodeJS stuff, and on a 1950 (I think that’s what you said it was) it could take QUITE a while, with slow disks and a slow CPU.

I’m going to have to put a ‘This can take a long time’ warning there.


It’s a Dell R210 ii with a 1240v3 actually so modern per se. Personally, I haven’t touched a Dell machine in years (since we normally use Supermicro).

Nevertheless, glad this is resolved.

P.S. - The GUI for CentOS 7 went directly to installing without any prompts, not sure if that’s how you guys meant to setup it up or not. Just found it a bit weird it started without asking me.

I’m guessing the disks are what’s slowing it down, in that case. There’s nothing really we can do about that, it’s just a bunch of iops are needed.

Yep, that’s as intended. If you don’t want it to auto-install, pick advanced. (The menu DOES say ‘Automatic Install’)


Samsung Enterprise SSD’s. :slight_smile: Not the disks…

Gotcha, anyways thanks for your help. When do you guys expect to have 7 released?

1 Like

Hmm, that’s worrying then. Can you try installing again, and this time watch the logs?

When is it released? When I’m happy with it, and I’m not happy with it if it’s taking an hour on SSDs 8)

How do I watch the logs? I didn’t see this option.

I’ve got to reinstall it anyways since I have been playing with the SIP settings with our new provider.

The easiest way (based on my preferences) is to log into your server as root and enter the following command:

tail -F /var/log/asterisk/full

You can watch the logs by logging in as root and starting “asterisk -vr” as well, but the full logs will give you more information.

Alt-F2 to go to a text window, and then run this

tail -f /mnt/sysimage/var/log/freepbx_rpm_install.log

That’ll show you what its doing while the RPM is installing.


Unfortunately, I was unable to install it this time (strangely enough) - it told me there were no drives, but the latest stable build worked perfectly and SIP is up and running… I had cleared the drives using the dd commands above like I had done before doing the CentOS 7 install, but no success this time. :frowning:

Guess I’m stuck with CentOS 6 for now.