10.0 feedback for the developers

4 days prior to the official release of ‘10.0’ I installed a new system. As in a ‘real’ installation taking over service from an ancient 5 line rollover POTS system.

Everything went incredibly well. The inbound fax to email wowed the client. The original fax machine sent faxes out over the GrandStream ATA without a hitch, The credit card verifier also worked without a hicccup. Even the ancient dialout modem performed well through the same ‘Line’ as the other outbound devices.
As soon as we opened for business after upgrading to the first ‘Official’ release of 10.0 we expereienced the following:

  1. unreliable credit card communications. We immediately plugged in to the still available pots line.

  2. ivr not playing the correct announcements

  3. Time groups/Time conditions not working as expected, possibly due to the above.

I managed to implement a work around using the call flow control.

I see where there has already been 2 subsequent release of modules that may ‘fix’ these issues I described.

The developement team needs to be congratulated by the community for a great job.

Knightflyer I am not sure exactly what the issues you are experiencing, and I have followed your posts as you seem to be struggling but never could put my finger on the issues.

With this new information I can tell you the following:

1 - FreePBX 2.10 is Beta I would never install it at a customer deployment unless I needed a specific feature. My company pays for development support on FreePBX and of course I am the CTO and with all of those resources we are deploying 2.9 currently.

2 - You didn’t mention what type of trunks you have. If you are using SIP trunks I am surprised your modems ever worked. If you are using POTS lines for this, TDM bridging on ZAP/DAHDI interfaces has worked in Asterisk since version 1.2 so if you are having issues you need to check your DAHDI config.

3 - FAX, Asterisk 1.8 included TDM gateway support. The FreePBX fax features have nothing to do with t.38 routing.

4 - I know of no active bugs in IVR and Time Conditions. Our largest Beta site on 2.10 have well over 100 extensions and a highly active call center professionally managed call center. That is just my companies testing. The community has 1000’s of beta sites and at least 100 reporting back into development.

You went out and talked one of your clients into the system. This is a common scenario. I bet you are a successful IT consultant. IP telephony is a unique skill set that and being proficient is not a part time endeavor. You are probably very frustrated and have a frustrated client.

I suggest you:

1 - Engage FreePBX official support and get your client on track
2 - If you want to be in the FreePBX integrator business join us at the next OTTS for 4 days of hard core bootcamping on what it takes to manage these systems.

  1. I only deployed 2.10 after reading that 2.10rc was as ready for deployment. In my experience the rc worked better than 10.0 ‘real’. My client of over 20years was well informed. Consider we replaced an antiquated sytsem without any features other than hold and rollover, it was a success. Forgive me if your perceptions of frustrations on our part were wrong.

  2. We are using sip trunks and yes I was suprised that the credit cards and the modem worked fine, at first with the RC. Then I was equally suprised that after the ‘real’ 10.0 released credit cards were having difficulty going through, after no problems for 4 days with the RC. I thought I was doing FreePBX a service by reporting this experience. The dialout modem is a separate issue we have had zero problems with the antique system still in use for stock orders to the vendors. The modem is soon to be phased out as there now exists an API. The same thing for credit cards.

  3. We never experienced any fax issues. I only reported great success.

  4. I also tried to report what I experienced in a trouble ticket. In my experience with mysql I suspect something got dinged up between releases of the candidate to final version. When I get back to my friend and customer’s site I will see if the latest deployment of 10.0 fixes the ivr/time conditions.

I only was giving feedback and thought it may be helpful.

This installation only has 10 extensions, but I assure you there is/was an issue with the ivr as I deployed a bi-lingual ivr on my test system and it worked flawlessly, as the Spanish branch correctly pre-pended cid with ‘ESP’ before going to the ring group which allowed our bilingual agents to grab. All worked flawlessly on the test system 2.9, and the 10.RC. and I suspect will on 10.0 soon.

Wrong IVR announcements after the caller presses his selection of ring group, is happening, at this installation. So I have disabled all IVRs and as stated elsewhere am using flow control and voice mail for the after hours ivr, and we don’t have a main greeting IVR until I am confident IVRs are fixed.

SkyKing I follow your advice and generally agree with you.

It is nice to know there are FreePBX professionals such as yourself out there. I suspect we shall get the IVR issue going without it. It probably has been fixed in one of the latest module releases I haven’t had a chance to install yet.

I would love to go to next OTTS, but the cost is prohibitive to me. I only support 2 small voip systems. I would however accept any invitation to ‘audit’ the gathering.

Nothing personal but we would have to rent an auditorium if we gave away free seats.

Anyway. I think you may have the Distro and the FreePBX versions confused.

Not exactly sure if you are talking about the costant FreePBX pushes as 2.10 nears release or the Distro update scripts.

To participate in the beta program you should be updating FreePBX nightly using the FreePBX module admin.

The IVR problems you are having sound like DTMF issues with Asterisk and your trunk/peer config. Nothing to do with FreePBX per se.

Also you success with Faxing is a mixed bag as FreePBX does not have anything to do with t.38 gateway or even packet 2 backet bridging. I suspect you have a good carrier and selected the right ATA’s. If you are using an Analog Digium/Sangoma card and are having success you have managed to do what the developers have not been able to get working with 100’s of hours of labor. If you are using ATA’s with t.38 or packet bridging you may want to share your experience with tuning Asterisk settings and ATA config to get it working properly.

Is 2.10 officially final as procalaimed on the right column of this web page?

As for our fax success. I merely provisioned for a normal extension on one of the two Grandstream FXS ports. I then took the 3way splitter/joiner that connects the (1.Fax 2.Serial Modem 3.Credit Card Verifier.) into said port.

All lines including the fax/modem/credit card are currently provided by Time-Warner. I merely forwaded all lines to our solo Vitelity Sip Account using Time-Warner’s tools.

I set inbound faxes to use the FreePBX feature to send to a fax recipient’s e-mail.

To test I used our old plain fax machine to fax to our published fax #. It correctly routed it to our Viteleity Sip and into the Office Manager’s email as we expected.
We receive more faxes than send but so far have had no issues with faxes inbound or out.

Eventually we will port the main number from the 5 line rollover system and abandon the other 4 uneeded pots lines. On advice from you and others we will keep one pots line for rainy days.

What I thought was the 10.0 Final may still have a problem with playing the wrong announcement. I just verified that our all agents busy ivr designed to be triggered after the ring group fails to answer in 45 seconds is incorrectly announcing our offices are closed, and this is an announcement that occurs before any dtmf input occurs. But I have not been on site to try the latest overnight releases. I have seen ivr has been updated. I do have a 10.0 system for my test system, I will see if it works on my system in the morning, and will report back.

With best regards,

Ok, now you are describing a time condition issue.

I just scanned the tracker and we have not had any time group/time condition or routing issues with 2.9 or 2.10.

I see Philippe announced as final so that is official word.

In my opinion not early adopted so still would vet and test. I generally stay 6 months behind on the releases vs what I push out to customer systems.

Keep in mind up to this year we build our own in house distro until the FreePBX distro came out.

In my opinion, based on my decades of database programming experience, there existed, probably in one of the RCs, a database indexing error. Probably when deleting/changing an announcement, an index pointer was not updated properly or my bad judgement in updating release candidates on a live system, or a combination thereof.

Let there be no confusion, I deleted all IVRs, and time groups.conditions etc. The only announcement being played was when using a ring group as a destination. It was totally unrelated to the defined announcement, and try as I may I couldn’t fix it by deleting or adding new announcements.

As of now on my test system (Asterisk 1.8.93 FreePBX 2.10.0 IVR Module I am able to create complex, ‘simulated bilingual’ ivrs with time groups/conditions and I have amended and changed announcements. so far everything checks OK.

After updating the live site with these latest modules, I will attempt to build/amend ivrs with my bilingual voice model. If the database index issue remains, and I cannot get the correct announcement with the action, I will install a virgin 10.0. Thank God I only have 10 extensions to worry about.

As it stands now my friend/customer is totally aware of what is going on, his phone system is delivering at least what he had with his old system, and he is happy.

And yes I have learned a lot, thanks to everyone involved.

It’s too bad you don’t have the system up that was doing this. Would have been interesting to poke around the DB and see what was really going on.

For now my friend/customer is happily running with just a voicemail after ring-group timesout.

So the database is in tact. I will be there early next week. But that could be an eternity in real-time.

If you really want I could ssh into one of the client pcs and do a mysqldump on the pbx.
if that would be useful.


Did you happen to run the upgrade “upgrade-”? I was also able to run credit cards and fax untill I ran this. I would guess to say it was an asterisk update. This will update asterisk from to It looks as if this might have caused it. Asterisk has a new version out now 1.8.10.