0 byte clearlydevices-14.0.27.tgz

I am trying to upgrade the module clearlydevices

fails with:

Error(s) downloading clearlydevices:

    Could not untar /var/www/html/admin/modules/_cache/clearlydevices-14.0.27.tgz to /var/www/html/admin/modules/_cache

it fails to untar because the file is empty:

:# ls -l  /var/www/html/admin/modules/_cache/clearlydevices-14.0.27.tgz
-rw-r--r-- 1 asterisk asterisk 0 Dec 29 15:06 /var/www/html/admin/modules/_cache/clearlydevices-14.0.27.tgz

is there an alternative way to download the module?

fwconsole ma download clearlydevices

You may try removing the cache file first


For reference My output…

No repos specified, using: [standard] from last GUI settings

Starting module download from http://mirror.clearlyip.com/modules/clearlydevices/clearlydevices-14.0.27.tgz ...
Module http://mirror.clearlyip.com/modules/clearlydevices/clearlydevices-14.0.27.tgz successfully downloaded
Chowning directories...Done

Please note these are considered 3rd party and unsupported so the best route may be to get in touch with our support if the above doesn’t handle it.

I happen to be around a lot but that can often be the quickest drama free point of contact :slight_smile:

that worked.
in addition at freepbx screen I had to enable and upgrade the module

dashboard shows it is running.

Thank you !

1 Like

Hello James
we are setting up a Debian 11 Freepbx test system , and i am unable to install the module using the instructions from above:

# fwconsole ma download clearlydevices
No repos specified, using: [standard] from last GUI settings

Downloading module 'clearlydevices'
The following error(s) occured:
 - Retrieved Module XML Was Empty

## try removing a possible existing file
ls  /var/www/html/admin/modules/_cache/clearlydevices-14.0.27.tgz
ls: cannot access '/var/www/html/admin/modules/_cache/clearlydevices-14.0.27.tgz': No such file or directory

## Perhaps the 0 byte file to remove is in a diff location [ due to centos & debian differences ] :
##  Nope this returned nothing:
locate clearlydevices

poking around https://www.clearlyip.com the other day i saw a link to download the module. will look again…

If you are using the default Sangoma mirrors then it won’t find it, you will need to install manually Installing the FreePBX Module

Alternatively you can switch to their mirror proxy Switching to Clearly IP Mirrors for FreePBX and then you will be able to download install in the usual way.

1 Like

Okay i setup the clearly repo.

on this debian 11 / asterisk 16 system the clearlydevices install failed

Please wait while module actions are performed
Upgrading clearlydevices to 14.0.27 from track stable
Downloading clearlydevices 1148086 of 1148300 (100%)

Installing clearlydevices
Updating tables clearlydevices_extension_mapping, clearlydevices_brand_common_code_translation, clearlydevices_brand_common_codes, 
clearlydevices_model_options_required, clearlydevices_models, clearlydevices_template_details, clearlydevices_template_device_details, clearlydevices_template_devices, clearlydevices_template_options, clearlydevices_templates, clearlydevices_apps, clearlydevices_rebuild...Done
Could not update database. Please contact support.

let me know if more info is needed.

Not sure if @jfinstrom can offer any advice? Alternatively it will need to be a support ticket to ClearlyIP.

Richard: Okay thanks. I’ll wait a few days before contacting support.

all: If more info is needed just ask.



since all the clearly modules are listed as commercial then that is the probable cause.

It’s not technically a Commercial Module, it’s a 3rd Party module. The reason that Sangoma Commercial Modules can’t be installed is related to SysAdmin Module and licensing requirements not being supported on other OS’s.

I know what you mean. debian is different then centos. so the sysadmin module can’t deal with dns and network settings .
anyway we have used debian for 20 years and i see no need for sysadmin . cli is so much more reliable then most gui . especially for upgrades.

Yeah I would go through support. Our stuff has nothing that specifically locks it in to EL distros.

Sangoma modules had that restriction Because of zendguard and how they manage licences. Technically 16 forward they are using ioncube so they could lift that restriction but that would require a bunch of other rewritten code.

When we started our new venture we worked really hard not to paint ourselves into a corner.with any of our technologies.

In any case I have not tested on debian because I still develop against SNG7 when writing FreePBX stuff. That said I’m pretty sure some we have a few debian folks from our update management partners so it should work fine.
.I am away from an actual computer tilomday so I can’t play with this unfortunately.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.