Sangoma Completes Acquisition of Digium: Sangoma Press Release. Community FAQ: Sangoma and Digium Join Together FAQ
FreePBX | Register | Issues | Wiki | Portal | Support

Zulu UC 3 and Mobile


(Ted) #21

Just tried a completely different subdomain.domain.com with the same exact configuration but still getting the same error.

Would logs show anything? Where should I look for the logs in this situation?


(Andrew Nagy) #22

Unfortunately this is an issue between your server and our mirror server. The way this works is that your server generates a random string. That random string is then passed back to our mirror server and then our mirror server connects to your url and verifies that the two string match, In your case they don’t. which means its not the right domain.


(Itzik) #23

No. It actually wasn’t disabled. FreePBX allows you to set port 80 dedicated to Let’s Encrypt, and in the same time set your GUI to a random port, so when you open port 80 on your Firewall for Let’s Encrypt to do the verification, you won’t expose your entire system…

So again, in order for Let’s Encrypt to access your server you have to set port 80 open to the world wide web. Once it’s done, you can close it again.


(Andrew Nagy) #24

Is the domain the same between these two machines?


(Avayax) #25

The let’s encrypt certificate gets renewed every few months. Does port 80 have to be open for this as well or only when creating the certificate?


(Ted) #26

The domain is the same, it’s just the subdomain that is different. Both are configured in google domains as a permanent redirect to point to the ip address. FreePBX 13 works, FreePBX 14 does not. Also It worked initially when I created the first certificate on the 14.


(Andrew Nagy) #27

So its separate domains pointing to separate ip addresses

pbx1.com => 1.1.1.1
pbx2.com => 1.1.1.2


(Ted) #28

yes one subdomain is one pbx, the other one is other pbx. Both have always worked as far as using those fqdns in the browser.


(Ted) #29

it’s actually one domain and different subdomains

sub1.domain.com => 1.1.1.1
sub2.domain.com => 1.1.1.2


(Itzik) #30

Yes, it technically creates a new cert.


(Ted) #31

So, why is my zulu desktop working and zulu mobile is not? Isn’t this the same app and same protocol to register on pbx?


(Tony Lewis) #32

Becauae mobile is a whole different code base from desktop because that is how mobile operating systems work. Mobile is also early beta where desktop has been out for 6 months now. On desktop we can work around issues with self signed certs but with mobile we are not able to due to again the mobile operating systems.


(Arton Bajrami) #33

Im havin same issue with zulu mobile app i have cert from lets encrypt and i have open port 8002 i can telnet to it so i know it works i have configure the app with

Account name test
User: username@fqdn.com
Password: *******
Server : fqdn.com

IOS Device

It trys to connects then it gose back to account connection is closed


(Andrew Nagy) #34

Username needs to be just the username. No @server.


(Arton Bajrami) #35

I have try all still same


(Ted) #36

So looks like FreePBX does not have an idea on how to fix this issue with LetsEncrypt not working? Why would it work after the install and wouldn’t work the second time it wanted to update the cert? Nothing was changed in the config or domain.


(Andrew Nagy) #37

It works fine with Let’s Encrypt. I don’t know what your issues are unfortunately (yes you’ve explained them but I’d just be guessing)


(Arton Bajrami) #38

Which ports do i need to open for zulu app to work 8002 and 8089 please let me know because the app not working for me thanks


(Avayax) #39

Only 8002.


(ADTopkek) #40

It’s beta for a reason.

I have not been able to connect even once with Zulu 3 and the mobile beta. No idea why. Not too concerned since it just got released though.