Zulu Mobile

freepbx
Tags: #<Tag:0x00007fafc3f340d8>

(Jason) #1

FreePBX 15.0.16.42
Asterisk 16.6.2
Zulu 1.0.7
Android version 10

When trying to setup Zulu through the UCP generated QR code, i’m getting “invalid QR code” when trying to register the Zulu Client.

I thought maybe the problem was that I was scanning from a monitor so I printed it out. Same result.

Any insight?


(Jason) #2

It’s not because of “dark mode” theme on the browser…

Have tried multiple browsers…


#3

Had the same issue


(Charles Darwin) #4

Did you configure the Zulu server with a valid SSL certificate, with a STUN server and port forwarding as described in the wiki?

https://wiki.freepbx.org/plugins/servlet/mobile?contentId=98699558#content/view/98699558

https://wiki.freepbx.org/plugins/servlet/mobile?contentId=110003971#content/view/110003971


(Jason) #5

Hello,

I do have a valid LE cert installed, HTTPS configured. I can manually connect the Zulu client with TLS and it works fine.

I also have the STUN setting in WEB RTC.

It just won’t scan the QR for autoprovision.

It’s a small annoyance, if I really need to fix it I can open a support ticket I suppose.


(David M. Lee) #6

@Scion,

A support ticket at support.sangoma.com is probably your best option for figuring this out.

Usually when there are problems using QR codes, it’s because of using an IP address or invalid hostname for accessing the UCP. The browser is much less picky about certificates than mobile clients, especially Android. But the error in those cases should specifically be about the certificate issue and not the generic “invalid QR code” error.

You’ll also see this error if the QR code has expired. QR codes are temporary tokens and only good for one hour; a permanent token is generated during the login process.