Zulu looking for old SSL cert

FreePBX: v14.0.5.25
PBX Firmware: 12.7.5-1902-3.sng7
PBX Service Pack:
Zulu: v3.2.1+14 © Sangoma

Last week, I replaced an expired SSL certificate. I generated a Let’s Encrypt cert on another system, then I imported it locally in the FreePBX interface. HTTPS is using the new cert (no issues there), and the new cert is set as the Default cert in Certificate Management.

I ran into an issue today when trying to make a call using my Zulu softphone. When I dialed the number, about the time the call should have connected, it just ended the call (no ring or anything).

I watched the Asterisk console (asterisk -r) while I tried dialing again, and I see a reference to my old certificate name. The old certificate has been deleted. I don’t recall if I deleted it directly in the file system or through the FreePBX interface while I was trying to remember how to update the cert…maybe that’s where the problem was introduced, if I deleted it from the file system…?

Here’s the console output:


I tried restarting the Zulu server, but no change. I also clicked “Import Locally” in Certificate Management, then set the “Default Self Signed Certificate” as default, and then set the default back to my current valid Let’s Encrypt cert. Still no change when trying to make a call. I also logged out & logged back in to my Zulu client several times throughout this process.

Where can I tell the system to look to


instead of


Another piece of info: the new cert is a multi-domain cert containing wildcards among other SANs.

I thought about restarting Asterisk & FreePBX, but I can’t do that during business operations, so if there’s a simpler way to resolve this, that would be very helpful.


I assume there’s some issues with the way you imported the cert.

Why didn’t you generate the new certificate on this machine?

This server doesn’t have external http access for verification of the cert.

I tried a fwconsole restart, and that didn’t work. Then I completely rebooted the server, and now I am able to call out using Zulu.

Does anyone know where that certificate setting changed? I probably did something wrong when loading in the new cert & removing the old one. Just wondering how I could fix (other than rebooting the server) it if this happens again next time.

Next time try restarting httpd

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.