Zulu login prompt when accessing UCP

FreePBX: v14.0.11
Asterisk: v13.22.0
PBX Firmware: 12.7.6-1904-1.sng7
PBX Service Pack:
Zulu module: (not licensed)

We had been on a trial of Zulu, but that has ended now. I have tried to turn off Zulu where I can, but when I login to the UCP I am getting this prompt for Zulu credentials:


I have tried setting the Zulu permissions in UCP to “No”. My FreePBX user account has this set to “Inherit” under Admin -> User Management -> my account -> UCP -> Zulu. Then, the groups I am a member of have this Zulu option set to “No”. I also just tried setting UCP -> Zulu to “No” for my account, and I still see this prompt.

The odd thing is… if I’m logged out of the UCP, I do not see the Zulu credential prompt on first login. It’s only when I’m already logged in and I open a new tab directly to the UCP or click the UCP link from the admin console – then I see the Zulu prompt. I’ve tried this in a private Firefox window with the same results.

Does this seem like a configuration error on my part, or is this potentially a bug?

Is it best to just disable this module since we don’t use it? I still like to keep all modules updated to maintain compatibility if we ever decide to license one of the commercial modules.

I believe stopping the service and disabling the module will not cause the module to stop receiving updates, I think you have to remove it.

I’d try removing Zulu from pm2 which should also stop it:

fwconsole pm2 --delete zulu

You can manually stop it if you want to be sure:

fwconsole stop zulu

And if it persists, disable the module

fwconsole ma disable zulu

Thanks for the quick reply!

If I remove Zulu from pm2 (Process Management), and 6 months down the road we want to purchase Zulu, will I be able to set it back up from the admin GUI, or will I have to do a manual step like this one?

I prefer to do as much as possible from the GUI to keep things on a level where other admins here can also easily manage things in my absence. I just disabled it in the GUI (same as fwconsole ma disable zulu I assume), and that seems to have stopped the extra login prompts.

Any ideas on whether or not this login prompt is a bug?

I’m not sure if the login prompt is a bug or not, you can check here: https://issues.freepbx.org or if you stil have an active license you can open a commercial support ticket.

As for re-enabling the service, this will not happen when you re-enable the module, it has to be done via the command line with fwconsole start zulu

Most things don’t require shell access but stopping and starting services generally does, if you have admins that take care of the server in your absence, having some of these things documented may be helpful in a pinch.

Thanks for the tip on the services vs modules. I will definitely add to our internal documentation some references to using fwconsole as well.

I’m not so concerned about the possibility of a bug anymore, although I did a cursory search and didn’t find any existing bugs that seemed related.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.