ZULU Calls Failure


(Hzh) #1

HI guys.
I tested zulu in few days ago but i have some problem with it.
I try to connect with zulu mobile app (on WAN connection), extention registried and its ok but when i try to make voice calls to another extention on my PBX, connection will be lost.
i checked pjsip logs and realized that RTP packets was send and recieved normaly but session will be lost.


(Psdk ) #2

Please share the logs.
Local calls are ok?

What about other calls on internet? not via ZULU.


(Hzh) #3

yes.we tested locally calls with zulu desktop and voice resieved and sent perfectly. we also registeried extentions with TLS on internet and it works well. i will send logs to you.


(Psdk ) #4

So, everything is normal, just you have problem with ZULU mobile?
Did u test ZULU desktop through WAN? it is ok?


(Shahin Nazir) #5

@psdk

  • So which Zulu Module version you are using ( running ) at the moment on your PBX? ( check pbx module updates )
  • Which SSL certificate you are using ? ( You must have installed SSL certificate on your PBX)
  • Check your Asterisk Sip Settings --> PJSIP Tab --> SSL/TLS Certificate : Select your SSL Certificate.
    check your SSL certificate with your FQDN name. ( you can use some internet pages 2nd Link )
  • Try to activate Opus Codec and STUN Server ( Asterisk settings --> General settings --> STUN : stun.l.google.com:19302 ) And bottom you can see CODECS activate Opus.
  • Last think check from your PBX internally SSL cert ( openssl s_client -showcerts -connect FQDN.com:8002 )
  • Router Firewall you must allow Zulu Port 8002 TCP ( Port Forward or NAT )

(Lorne Gaetz) #6

Zulu mobile is not supported on 13.


(Hzh) #7

hi @shahin . thanks for your reply. i did this steps and checked them too:

1- i’m using zulu module version 15.0.58.3 in my pbx
2-i installed SSL Certification that issued by Let’s Encrypt
3-PJSIP’S certificate manager sets on SSL certification
4-i tested this topic with the tools that you mentioned and my domain resolved to an ip that our SSL Certification is based an create on it.
finaly, please check this log message from zulu :

2020-07-18 9:30 +04:30: e[31m[2020-7-18 9:30:06.401] [ERROR] console - e[39mAsterisk proxy error {“message”:“connect ECONNREFUSED 127.0.0.1:8089”,“stack”:“Error: connect ECONNREFUSED 127.0.0.1:8089\n at Object._errnoException (util.js:992:11)\n at _exceptionWithHostPort (util.js:1014:20)\n at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1186:14)”,“code”:“ECONNREFUSED”,“errno”:“ECONNREFUSED”,“syscall”:“connect”,“address”:“127.0.0.1”,“port”:8089,"__error_callsites":[{},{},{}]}


(Shahin Nazir) #8

Hi @hosetsuko
Zulu always use 8002 TCP ports pls go go Advance settings --> Bottom on the page --> Zulu and check your active Zulu Ports.
Pls try to run below command:

openssl s_client -showcerts -connect FQDN.com:8002


(Hzh) #9


hi @shahin. i used 8002 for zulu client.


(Shahin Nazir) #10

@hosetsuko what about your ssl certificate ? Also pls check your Router Firewall ( NAT or Port Forward ) to Your PBX IP Address.

  • Let’s Encrypt --> 80 TCP
  • Zulu Module --> 8002 TCP
  • RDP --> 10K-20K UDP
  • UCP for Scan QR Code --> 4443 TCP
  • STUN Server --> stun.l.google.com:19302 ( PBX GUI --> Settings --> Asterisk Sip Settings --> General Sip Settings --> Media Transport Settings )
  • ICE Host Candidates --> 192.168.xx.xx(local network) => XX.XX.XX.XX ( Public Wan Network ) you can add. ( PBX GUI --> Settings --> Asterisk Sip Settings --> General Sip Settings --> ICE Host Candidates --> IP Addresses ) Add.

Thanks.