Zulu (Android) Shows Connected But Calls Do Not Come In, Extension Showing Unavailable in Peers & Logs


#1

FREEPBX 14 with Zulu 3, module version 14.0.58.0

We have Zulu running on two Android based phones (this issue happens on both). The Zulu app connects right away upon opening. On the Zulu server status page, in the Active Session tab, it correctly shows the Connected At time, client version (3.0.1) and client type (android-28).

However, in Asterisk Info > Peers, both are showing as unavailable:

Endpoint: 905001/5001 Unavailable 0 of inf
InAuth: 905001-auth/905001
Aor: 905001

Endpoint: 905014/5014 Unavailable 0 of inf
InAuth: 905014-auth/905014
Aor: 905014

And when doing a test call to a ring group that includes both extensions, the call fails because no extensions are available. Here is the log.

Added extension 5001 to extension map
Added extension 5014 to extension map
Extension 5001 cf is disabled
Extension 5014 cf is disabled
Extension 5001 do not disturb is disabled
Extension 5014 do not disturb is disabled
EXTENSION_STATE: 4 (UNAVAILABLE)
Extension 5001 has ExtensionState: 4
Checking CW and CFB status for extension 5001
Extension 5001 is not available to be called
EXTENSION_STATE: 4 (UNAVAILABLE)
Extension 5014 has ExtensionState: 4
Checking CW and CFB status for extension 5014
Extension 5014 is not available to be called
Filtered ARG3:
Setting default NOANSWER DIALSTATUS since no extensions available

The only way I’ve been able to force the extensions to be available is to make an outbound call from Zulu on each phone. This causes them to show as Available in Peers, and then incoming calls don’t fail anymore (and two way audio works). If left long enough, maybe 20 or 30 minutes, it eventually goes back to Unavailable.

I need assistance finding out why Zulu extensions are showing as unavailable.


(David M. Lee) #2

@drummerjoe,

VoIP works differently with mobile. The mobile app cannot stay up and registered constantly; that would quickly drain the battery on your mobile device.

Instead Zulu Server sends a push notification to the device, which wakes up the Zulu Mobile application so it can ring the device, connect to Zulu, and all the other stuff it needs to do.


(Jared Busch) #3

@drummerjoe ZoIPer has (well had in v4, I don’t use v5) an OMG kill my battery mode if you want to experience what @dlee just described.


#4

Try TCP instead of UDP if using Zoiper or other soft-phone on battery operated things, I am sure you will notice the difference.


#5

Got it - so that answers why it would show as unavailable when idle. However, it doesn’t explain why when we are doing test calls, the mobile phone doesn’t ring and the log shows the extensions as unavailable. Wouldn’t this mean the push message isn’t being sent?


(David M. Lee) #6

The behavior you’re describing would happen on a very old version of the mobile client (when push notifications worked very differently). Check the Settings panel in the mobile client and confirm that you’re running the latest (1.0.7).

In the FreePBX Admin UI, under Admin -> Zulu -> Mobile Tokens, there are buttons for both sending test push notifications and for viewing the push logs. That might help you narrow things down.

If that doesn’t help, you can open a support ticket at support.sangoma.com.

Good luck!