ZeroTouch Config issues


I just purchased a new S505 and I’m trying to use ZeroTouch Provisioning through your Redirect Service. However, in each case, it just brought me to a screen on the phone with the history button at the bottom and a lightning bolt icon at the top but no login button to connect to the system.

To ensure that the phone was able to connect to the system at all, I configured an extension in freepbx and put the mac address for the phone. Now the phone won’t stop “provisioning” with that extension even though the extension has been deleted. I have tried multiple factory resets to no avail. Can you help me get this phone setup for using your ZeroTouch provisioning.

Hi Bob

Have you come across the Wiki page for ZeroTouch?

Hi Steve,

Thank you very much for the reply I went through that wiki article yesterday. There was one step that I didn’t do that was exact the first time through. I had the firmware set to recommended which doesn’t look like it was getting the latest firmware. So this time I configured the firmware slot and selected firmware slot 1 and it gave me the login button.

However, I decided to factory reset the phone so I could make sure this was working consistently. I removed the phone from the redirect server and re-added it through the portal. I then removed the extension mapping from freepbx and made sure the mac address wasn’t associated with the extension. I then did a factory reset on the phone and attempted to let it go through setup again. Once the phone booted back up, I was not presented with a login button. I was presented with this screen: firstscreen then a few seconds after I was presented with this screen: secondscreen

It’s worth noting that the first time through, it downloaded a new firmware and it looks to be a newer version (has the new sangoma logo). However, the second time it doesn’t even appear to be provisioning anything from the freepbx server (the default password is still admin instead of what was set in freepbx)

sangoma_default is the default template.

This is wrong. The phone downloads a file from /tftpboot, deleting the extension won’t delete that file… So as long as the file is there it will provision with that file.

Now back to the Zero touch provisioning issue.

Please explain what you did in the portal, where did you point it to? Etc.

Hi PitzKey,

Thanks for the response. I’m not certain what the issue was with the phone “keeping” the last good config but I removed it from the redirect server and readded it and that problem went away. I opened a support ticket with Sangoma and after a few hours they figured out what was going on. Here’s the steps the technician told me he used:

  • Login Sangoma Portal --> Phones --> MAC address --> Zero Touch Configuration Enable --> IP/FQDN : --> Save / Submit
  • PBX --> System Admin --> Provisioning Ports --> HTTP --> 84 Checked
  • PBX --> Connectivity --> Services --> HTTP Provisioning --> INTERNET / LOCAL / OTHER Allowed.
  • PBX --> EPM --> Global Settings --> Internal Address :
  • PBX --> EPM --> Template --> Sangoma --> sangoma Default --> General Tab --> Provisioning Address --> Internal OR Custom ( --> Save and Submit
  • PHONE Factory Reset

Looking through that, this is more of a documentation issue than anything. The docs say nothing about connectivity > services > http provisioning or setting the Provisioning address in the template. Phone works like a swiss car now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.