Zaptel does not load after yup update and freepbx 2.6.0beta 22 update

I updated with yum update and then updated Freepbx module (through module aDMIN) TO FREEPBX 2.6.0 BETA 22. since then my digium x100p card does not work. Looking by lsmod i saw the zaptel module is not loaded. ztcfg command does not work producing the message: Line 0: Unable to open master device "/dev/zap/ct1’.
I would hate to reinstall a previous version. Anybody have any idea of the solution?


Cent OS 5.3
asterisk 1.4.22

doing a yum update along with updating everything else is a really bad idea.

There should not be anything in 2.6 that would effect zap, we really don’t do anything with it and don’t mess with any of the zapata files.

I saw your post over in the trixbox forum.

Trying to obfuscate what your actual configuration is will not help you get support. It will actually get you ignored.

This is not a FreePBX issue. If you had posted your Zap/Asterisk and Kernel version (uname -r) someone could have helped you.

You might want to give it a go in the trixbox forum again with that info.

The FreePBX folks are not here to help the trix users. We lost that option in the community when Fonality thought it would be a bright idea to fork FreePBX.

Thank you for the responses guys. I was very frank about the issue. I agree with Philip, it was a bad idea to update many things together. I tried to be as clear as possible but forgive my ignorance (I am not an experienced user).I applied first yum update and then updated to FREEPBX 2.6.0 BETA 22 through the freepbx interface (which by the way i find a lot more useful than the trixbox interface). I do not know what is to blame for the problem.

I am not looking for free support. I can have everything up and running in 15 minutes with my restore images. I tried to contribute a little bit form the user point of view by reporting a problem that appeared when i updated my system with the beta.
I would like to thank you again for your time

You are doing a great job with Freepbx



kernel 2.6.18-128.1.10.el15
zaptel version (modinfo zaptel)
Asterisk 1.4.22