Zap extension caller id

ok, small problem that’s driving me crazy.

Analogue phone connected to FXS card configured as xtn 101
SIP phone connected via IP as xtn 102

Call 101 from SIP phone, analogue phone rings - good.
Call 102 from analogue phone, SIP phone rings but shows ‘UNKNOWN’ on display, shouldnt it show 101? or the name assigned in freePBX ?

Using 2.3beta 1 on asterisk 1.2 (lasest revisions)

Have I set it up wrong or is this just the way it goes?

Hi Dirk, I have the same problem with a Sangoma FXS port, the caller id is not shown when I call another extension, did you were able to solve the problem?

If I find the solution I’ll let you know.

Thanks in Advance,
Roberto.

You will have to edit your zapata.conf and added a “callerid=xxx” statement for each of your analogue extensions just above the "channel= " option. Hope this helps.

Kevin

Thanks a lot Kevin, it worked perfectly.

Just a question, I did the test and in the SIP Phone the name of the caller is shown (this is part of what I’m looking for) the other thing I need is to also show callerid number, do you know if this can be done (show the callerid number and name at same time, maybe something like “220-Roberto”)?

Best Regards,
Roberto