ZAP Device

FreePBX after new <a=>installation
Is missing “Generic ZAP Device” in Extension.

How to enable “Generic ZAP Device”?

Zaptel drivers were replaced by DAHDI in Asterisk 5 years ago.

My “old” system:
FreePBX 2.8.1
Zaptel driver not exists:
# lsmod | grep -i zap
zaphfc 53680 0
dahdi 239408 130 rcbfx,r1t1,dahdi_echocan_oslec,rxt1,wcopenpci,zaphfc,ax1600p,dahdi_dynamic,ap400,ystdm16xx,ystdm8xx,opvxa1200,xpp,dahdi_transcode,wcb4xxp,wctdm,wcfxo,wctdm24xxp,wcte11xp,wct1xxp,wcte12xp,dahdi_voicebus,opvxd115,wct4xxp

"Generic ZAP Device" in Extension - Exists!!!

I want to put a new server (FreePBX 2.11). How to?

I don’t understand your last question:

“I want to put in a new server, how to”

Zap was replaced with DAHDI some time ago. FreePBX referred to things as Zap and ran a compatibility mode. Over the years it’s all been cleaned up everything properly refers to DAHDI.

Asterisk has not supported DAHDI since 1.4, and the oldest asterisk supported by FreePBX 2.11 is 1.8. Asterisk 1.8 only uses DAHDI drivers.

Does this make sense?


I downgrade to FreePBX from svn.
Option “Generic ZAP Device” in Extension in Applications exists!

perhaps it is a bug in…

Listen to me, it’s not a bug. FreePBX 2.11 does not support Zap.

You should not be running Zap either.

In 2.11 use “Generic DAHDI device”

DAHDI replaced Zap in Asterisk 1.6 and forward.

Don’t say something is a bug when I have explained to you that support for end of life Asterisk/Zaptel was dropped.

If you look when you assign extension in 2.10 it says “Zap in DAHDI compatability mode” in 2.11 it was cleaned up and only DAHDI is listed.

You would have the functionality you want with a generic DAHDI extension.

Thank you! I will try to sort out.