yum1.freepbxdistro.org is down

yum1.freepbxdistro.org is down, yum2.freepbxdistro.org works

here is the error from the firstboot log.

http://yum1.freepbxdistro.org/centos/6.3/os/i386/repodata/repomd.xml: [Errno 12] Timeout on http://yum1.freepbxdistro.org/centos/6.3/os/i386/repodata/repomd.xml: (28, ‘connect() timed out!’)
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: base. Please verify its path and try again
traperr

I also tried the URL from two different computers with different ISP’s.

As far as I can tell, yum2 is down too:
[email protected]:~$ ping -n yum2.freepbxdistro.org
PING yum2.freepbxdistro.org (199.102.239.142) 56(84) bytes of data.
^C
yum2.freepbxdistro.org ping statistics —
16 packets transmitted, 0 received, 100% packet loss, time 14999ms

It just doesn’t respond to pings…

None of them ping for me, I determined that yum1 was down based of the error message.

I tested yum2 and yum3 in my browser with the link from the firstboot log:

http://yum1.freepbxdistro.org/centos/6.3/os/i386/repodata/repomd.xml: [Errno 12] Timeout on

That was all my fault. yum.freepbxdistro.org is round robin DNS to what was 3 yum servers and we brought up a 4th in a new datacenter for better failover and redundancy and I spaced out adding a firewall rule to the juniper for port 80 for the yum repos. All fixed now.

Also none of our servers allow pings to help cut down on people just looking for responses on IPs

I worked around it by putting a hosts entry with yum1 using yum2’s IP address :slight_smile:

Thanks for fixing it.