Yum upgrade or update failing

Hi Folks,

I’m just running yum update (and yum upgrade) on my system and have the following going on.

[[email protected] ~]# yum update Loaded plugins: fastestmirror, versionlock Loading mirror speeds from cached hostfile Resolving Dependencies --> Running transaction check ---> Package at.x86_64 0:3.1.13-22.el7 will be updated ---> Package at.x86_64 0:3.1.13-22.el7_4.2 will be an update ---> Package bind-libs.x86_64 32:9.9.4-51.el7_4.1 will be updated ---> Package bind-libs.x86_64 32:9.9.4-51.el7_4.2 will be an update ---> Package bind-libs-lite.x86_64 32:9.9.4-51.el7_4.1 will be updated ---> Package bind-libs-lite.x86_64 32:9.9.4-51.el7_4.2 will be an update ---> Package bind-license.noarch 32:9.9.4-51.el7_4.1 will be updated ---> Package bind-license.noarch 32:9.9.4-51.el7_4.2 will be an update ---> Package bind-utils.x86_64 32:9.9.4-51.el7_4.1 will be updated ---> Package bind-utils.x86_64 32:9.9.4-51.el7_4.2 will be an update ---> Package binutils.x86_64 0:2.25.1-32.base.el7_4.1 will be updated ---> Package binutils.x86_64 0:2.25.1-32.base.el7_4.2 will be an update ---> Package device-mapper-multipath.x86_64 0:0.4.9-111.el7 will be updated ---> Package device-mapper-multipath.x86_64 0:0.4.9-111.el7_4.2 will be an update ---> Package device-mapper-multipath-libs.x86_64 0:0.4.9-111.el7 will be updated ---> Package device-mapper-multipath-libs.x86_64 0:0.4.9-111.el7_4.2 will be an update ---> Package device-mapper-persistent-data.x86_64 0:0.7.0-0.1.rc6.el7 will be updated ---> Package device-mapper-persistent-data.x86_64 0:0.7.0-0.1.rc6.el7_4.1 will be an update ---> Package dhclient.x86_64 12:4.2.5-58.el7.centos will be updated ---> Package dhclient.x86_64 12:4.2.5-58.el7.centos.1 will be an update ---> Package dhcp-common.x86_64 12:4.2.5-58.el7.centos will be updated ---> Package dhcp-common.x86_64 12:4.2.5-58.el7.centos.1 will be an update ---> Package dhcp-libs.x86_64 12:4.2.5-58.el7.centos will be updated ---> Package dhcp-libs.x86_64 12:4.2.5-58.el7.centos.1 will be an update ---> Package initscripts.x86_64 0:9.49.39-1.el7 will be updated ---> Package initscripts.x86_64 0:9.49.39-1.el7_4.1 will be an update ---> Package iwl100-firmware.noarch 0:39.31.5.1-57.el7 will be updated ---> Package iwl100-firmware.noarch 0:39.31.5.1-58.el7_4 will be an update ---> Package iwl1000-firmware.noarch 1:39.31.5.1-57.el7 will be updated ---> Package iwl1000-firmware.noarch 1:39.31.5.1-58.el7_4 will be an update ---> Package iwl105-firmware.noarch 0:18.168.6.1-57.el7 will be updated ---> Package iwl105-firmware.noarch 0:18.168.6.1-58.el7_4 will be an update ---> Package iwl135-firmware.noarch 0:18.168.6.1-57.el7 will be updated ---> Package iwl135-firmware.noarch 0:18.168.6.1-58.el7_4 will be an update ---> Package iwl2000-firmware.noarch 0:18.168.6.1-57.el7 will be updated ---> Package iwl2000-firmware.noarch 0:18.168.6.1-58.el7_4 will be an update ---> Package iwl2030-firmware.noarch 0:18.168.6.1-57.el7 will be updated ---> Package iwl2030-firmware.noarch 0:18.168.6.1-58.el7_4 will be an update ---> Package iwl3160-firmware.noarch 0:22.0.7.0-57.el7 will be updated ---> Package iwl3160-firmware.noarch 0:22.0.7.0-58.el7_4 will be an update ---> Package iwl3945-firmware.noarch 0:15.32.2.9-57.el7 will be updated ---> Package iwl3945-firmware.noarch 0:15.32.2.9-58.el7_4 will be an update ---> Package iwl4965-firmware.noarch 0:228.61.2.24-57.el7 will be updated ---> Package iwl4965-firmware.noarch 0:228.61.2.24-58.el7_4 will be an update ---> Package iwl5000-firmware.noarch 0:8.83.5.1_1-57.el7 will be updated ---> Package iwl5000-firmware.noarch 0:8.83.5.1_1-58.el7_4 will be an update ---> Package iwl5150-firmware.noarch 0:8.24.2.2-57.el7 will be updated ---> Package iwl5150-firmware.noarch 0:8.24.2.2-58.el7_4 will be an update ---> Package iwl6000-firmware.noarch 0:9.221.4.1-57.el7 will be updated ---> Package iwl6000-firmware.noarch 0:9.221.4.1-58.el7_4 will be an update ---> Package iwl6000g2a-firmware.noarch 0:17.168.5.3-57.el7 will be updated ---> Package iwl6000g2a-firmware.noarch 0:17.168.5.3-58.el7_4 will be an update ---> Package iwl6000g2b-firmware.noarch 0:17.168.5.2-57.el7 will be updated ---> Package iwl6000g2b-firmware.noarch 0:17.168.5.2-58.el7_4 will be an update ---> Package iwl6050-firmware.noarch 0:41.28.5.1-57.el7 will be updated ---> Package iwl6050-firmware.noarch 0:41.28.5.1-58.el7_4 will be an update ---> Package iwl7260-firmware.noarch 0:22.0.7.0-57.el7 will be updated ---> Package iwl7260-firmware.noarch 0:22.0.7.0-58.el7_4 will be an update ---> Package iwl7265-firmware.noarch 0:22.0.7.0-57.el7 will be updated ---> Package iwl7265-firmware.noarch 0:22.0.7.0-58.el7_4 will be an update ---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.151-5.b12.el7_4 will be updated ---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.161-0.b14.el7_4 will be an update ---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.151-5.b12.el7_4 will be updated ---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.161-0.b14.el7_4 will be an update ---> Package kernel.x86_64 0:3.10.0-693.17.1.el7 will be installed ---> Package kernel-headers.x86_64 0:3.10.0-693.11.6.el7 will be updated ---> Package kernel-headers.x86_64 0:3.10.0-693.17.1.el7 will be an update ---> Package kmod.x86_64 0:20-15.el7_4.6 will be updated ---> Package kmod.x86_64 0:20-15.el7_4.7 will be an update ---> Package kmod-libs.x86_64 0:20-15.el7_4.6 will be updated ---> Package kmod-libs.x86_64 0:20-15.el7_4.7 will be an update ---> Package kpartx.x86_64 0:0.4.9-111.el7 will be updated ---> Package kpartx.x86_64 0:0.4.9-111.el7_4.2 will be an update ---> Package libdb.x86_64 0:5.3.21-20.el7 will be updated ---> Package libdb.x86_64 0:5.3.21-21.el7_4 will be an update ---> Package libdb-utils.x86_64 0:5.3.21-20.el7 will be updated ---> Package libdb-utils.x86_64 0:5.3.21-21.el7_4 will be an update ---> Package linux-firmware.noarch 0:20170606-57.gitc990aae.el7 will be updated ---> Package linux-firmware.noarch 0:20170606-58.gitc990aae.el7_4 will be an update ---> Package mongodb-server.x86_64 0:2.6.12-4.el7 will be updated ---> Package mongodb-server.x86_64 0:2.6.12-5.el7 will be an update ---> Package python-perf.x86_64 0:3.10.0-693.11.6.el7 will be updated ---> Package python-perf.x86_64 0:3.10.0-693.17.1.el7 will be an update ---> Package systemd.x86_64 0:219-42.el7_4.4 will be updated ---> Package systemd.x86_64 0:219-42.el7_4.6 will be an update ---> Package systemd-libs.x86_64 0:219-42.el7_4.4 will be updated ---> Package systemd-libs.x86_64 0:219-42.el7_4.6 will be an update ---> Package systemd-sysv.x86_64 0:219-42.el7_4.4 will be updated ---> Package systemd-sysv.x86_64 0:219-42.el7_4.6 will be an update ---> Package tuned.noarch 0:2.8.0-5.el7 will be updated ---> Package tuned.noarch 0:2.8.0-5.el7_4.2 will be an update ---> Package yaml-cpp.x86_64 0:0.5.1-6.el7 will be updated ---> Package yaml-cpp.x86_64 0:0.5.3-7.el7 will be an update --> Finished Dependency Resolution --> Running transaction check ---> Package kernel.x86_64 0:3.10.0-514.26.2.el7 will be erased --> Processing Dependency: kernel(skb_clone_tx_timestamp) = 0x83433c92 for package: kmod-forcedeth-0.65-1.sng7.x86_64 --> Running transaction check ---> Package kmod-forcedeth.x86_64 0:0.65-1.sng7 will be erased --> Processing Dependency: kmod-forcedeth for package: sangoma-pbx-1801-3.sng7.noarch --> Running transaction check ---> Package sangoma-pbx.noarch 0:1801-3.sng7 will be erased --> Finished Dependency Resolution Error: Trying to remove "sangoma-pbx", which is protected And I get the same thing with either update or upgrade.

Any ideas?

1 Like