Yum update rollback?

I’ve noticed a trend that after running a yum update on a fresh freepbx14 distro the system grinds to a halt. 5-10 minutes to shutdown and bootup. terrible audio quality. Prior to the yum update the system is super fast. Is there anyway to go backwards?

Not really. You’ve updated hundreds of packages and wouldn’t be able to pinpoint which ones you updates and which ones have deps on other packages. Not to mention kernel upgrades.

1 Like

This has happened on 5 systems so I don’t think it is a random issue. Is there anyway to determine what might be slowing the system down?

I didn’t say it was a random issue. I just told you that there is no way to go backwards. Sorry.

my bad. I didn’t mean to imply that. I appreciate you responding.

Do you think running yum update again (5-6d later) might fix it? I was thinking others have noticed this as well.

Restore from backup.

1 Like

Does a restore from backup restore just the extension/inbound routes etc or does it also take it back to the operating system version?

As per https://wiki.freepbx.org/display/FPG/Using+the+Backup+module it backs up “your PBX phone system settings and configurations”. I use that in addition to my VM snapshot tool before upgrading my PBX. So yeah, you are not in luck if you only used the freepbx backup.

What specs does your server have, and did you actually watch it rebooting to see where it gets stuck?

Intel NUC w i3 processor. 4G RAM. Really fast system normally. I’ll check tomorrow where exactly it sticks. It’s almost right off the bat upon boot and shut down

I updated the system updates over the weekend and I could not do a remote reboot, had to unplug and plug back in. Now on most every call the audio drops out and I am canceling appointments to try to get onsite to resolve it. Not a happy FREEPBX client now after working GREAT for 2 months, I won’t be doing anymore updates on my installs.

My testing has shown you are safe with module updates but system updates cause everything to slow down. To clarify my earlier post my processor is a Celeron not an i3 for these systems.

Sorry to hear this but you are very much alone in your conclusions. We have a large university (2000 extensions, 60+ concurrent calls) on the latest system updates and they don’t have issues.

Additionally the SNG 7 distro is 95% upstream from CentOS which gets it’s packages from Red Hat.

So you can blame “FREEPBX” or “Sangoma” all you want but if it’s not reproducible for us it’s hard for us to do anything about it and since we don’t have any control over 95% of the packages it’d be hard for us to solve this for you.

1 Like

Not trying to blame anyone here, just trying to find similarities.

mtntech - Do any of these match your server?

  1. Celeron Processor
  2. Intel NUC for your server
  3. FreePBX OEM partner

Andrew - If I create a replica server and open a paid support ticket could we investigate further?


I have a genuine FreePBX phone system 40 … Only owned it for 3 months only using sangoma phones, I guess I can pay for support if I can’t figure my issue out … so frustrating. Calls can be made and received but after 8-20 seconds the incoming audio is getting cut off, sometimes it comes back. Worked GREAT for months before I did the updates this weekend and tried to get a phone connected via VPN

My remote extensions have no customer audio coming from the outside into the PBX and to the extension

I should probably create a new post for my problems, close to formatting and starting over. Only a 4 phone setup.

Had your network changed? Router firmware updates?

Have you changed your router settings? Particularly to RTP/UDP timeouts, etc.

have you checked the asterisk log to see what’s going wrong?
I would do a cat /var/log/asterisk/errors to start some troubleshooting

1 Like