Yum Update Failing after upgrade to FreePBX 15


(Jay Zimmerman) #1

I upgraded from 14 to 15 using the upgrade module.

Now I am receiving this error when trying to run Yum Update

[root@localhost ~]# yum update
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile

One of the configured repositories failed (Unknown),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=<repoid> ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable <repoid>
    or
        subscription-manager repos --disable=<repoid>

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: schmooze-commercial/7/x86_64
You have mail in /var/spool/mail/root


(Jay Zimmerman) #2


(Jay Zimmerman) #3

I tried yum clean all, Any other suggestions?


(Jay Zimmerman) #4

Output of: sudo URLGRABBER_DEBUG=1,/tmp/debug.log yum update

[root@localhost ~]# sudo URLGRABBER_DEBUG=1,/tmp/debug.log yum update

  • Closing connection 0
  • Closing connection 1
  • Closing connection 2
    Loaded plugins: fastestmirror, kmod
  • Closing connection 3
  • Closing connection 4
  • Closing connection 5
  • Closing connection 6
  • Closing connection 7
  • Closing connection 8
  • Closing connection 9
  • Closing connection 10
  • Closing connection 11
    Loading mirror speeds from cached hostfile
  • Trying 162.253.134.145…
  • TCP_NODELAY set
  • connect to 162.253.134.145 port 80 failed: Connection refused
  • Trying 199.102.239.49…
  • TCP_NODELAY set
  • Connected to mirrorlist.schmoozecom.net (199.102.239.49) port 80 (#12)

GET /?release=7&arch=x86_64&repo=schmooze-commercial HTTP/1.1
Host: mirrorlist.schmoozecom.net
User-Agent: urlgrabber/3.10 yum/3.4.3
Accept: /

< HTTP/1.1 200 OK
< Date: Tue, 21 Apr 2020 14:24:13 GMT
< Server: Apache
< X-Powered-By: PHP/5.3.28
< Content-Length: 0
< Connection: close
< Content-Type: text/html; charset=UTF-8
<

  • Closing connection 12

One of the configured repositories failed (Unknown),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=<repoid> ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable <repoid>
    or
        subscription-manager repos --disable=<repoid>

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: schmooze-commercial/7/x86_64


(Jay Zimmerman) #5

If I disable the schmooze-commercial repo “yum --disablerepo=schmooze-commercial check-update” it completes the rest of the update without any issues. How do I correct the baseurl?


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.