Yum update error


#1

Hi

When Itry to update the system I get the below error
How can I fix this?

Setting up Update Process
Resolving Dependencies
–> Running transaction check
—> Package apcupsd.x86_64 0:3.14.10-1.el6.rf will be updated
—> Package apcupsd.x86_64 0:3.14.10-2.el6 will be an update
—> Package asterisk-sounds-core-en-alaw.noarch 0:1.4.21-1_centos5 will be updated
—> Package asterisk-sounds-core-en-alaw.noarch 0:1.4.24-1.el6 will be an update
–> Processing Dependency: asterisk-sounds-core-en = 1.4.24-1.el6 for package: asterisk-sounds-core-en-alaw-1.4.24-1.el6.noarch
–> Processing Dependency: asterisk >= 1.4.0 for package: asterisk-sounds-core-en-alaw-1.4.24-1.el6.noarch
—> Package asterisk-sounds-core-en-gsm.noarch 0:1.4.21-1_centos5 will be updated
—> Package asterisk-sounds-core-en-gsm.noarch 0:1.4.24-1.el6 will be an update
—> Package asterisk-sounds-core-en-ulaw.noarch 0:1.4.21-1_centos5 will be updated
—> Package asterisk-sounds-core-en-ulaw.noarch 0:1.4.24-1.el6 will be an update
—> Package fail2ban.noarch 0:0.8.8-94_el6 will be updated
—> Package fail2ban.noarch 0:0.8.10-3.el6 will be an update
–> Processing Dependency: python-inotify for package: fail2ban-0.8.10-3.el6.noarch
–> Processing Dependency: ed for package: fail2ban-0.8.10-3.el6.noarch
—> Package jack-audio-connection-kit.x86_64 0:0.116.1-6_1.el6 will be updated
—> Package jack-audio-connection-kit.x86_64 0:0.121.3-1.el6 will be an update
—> Package libpri.x86_64 0:1.4.12-6_centos6 will be updated
—> Package libpri.x86_64 0:1.4.13-1.el6 will be an update
—> Package libpri-devel.x86_64 0:1.4.12-6_centos6 will be updated
—> Package libpri-devel.x86_64 0:1.4.13-1.el6 will be an update
—> Package libresample.x86_64 0:0.1.3-11_centos6 will be updated
–> Processing Dependency: libresample.so.1.0()(64bit) for package: asterisk18-core-1.8.23.1-24_centos6.x86_64
—> Package libresample.x86_64 0:0.1.3-12.el6 will be an update
—> Package lua-dbi.x86_64 0:0.5-2.el6 will be updated
—> Package lua-dbi.x86_64 0:0.5-5.el6 will be an update
—> Package mosh.x86_64 0:1.2-2.el6 will be updated
—> Package mosh.x86_64 0:1.2.4-1.el6 will be an update
—> Package openvpn.x86_64 0:2.0.9-1.el6.rf will be updated
—> Package openvpn.x86_64 0:2.3.2-2.el6 will be an update
–> Processing Dependency: libpkcs11-helper.so.1()(64bit) for package: openvpn-2.3.2-2.el6.x86_64
—> Package portaudio.x86_64 0:19-6_4_20071207.el6 will be updated
—> Package portaudio.x86_64 0:19-9.el6 will be an update
—> Package prosody.x86_64 0:0.8.2-5shmz will be updated
—> Package prosody.x86_64 0:0.8.2-6.el6 will be an update
—> Package spandsp.x86_64 0:0.0.6-0.1.pre12.el6 will be updated
—> Package spandsp.x86_64 0:0.0.6-0.8.pre21.el6 will be an update
—> Package spandsp-devel.x86_64 0:0.0.6-0.1.pre12.el6 will be updated
—> Package spandsp-devel.x86_64 0:0.0.6-0.8.pre21.el6 will be an update
—> Package sqlite2.x86_64 0:2.8.17-8.el6 will be updated
—> Package sqlite2.x86_64 0:2.8.17-10.el6 will be an update
–> Running transaction check
—> Package asterisk.x86_64 0:1.8.20.0-1.el6 will be installed
—> Package asterisk-sounds-core-en.noarch 0:1.4.24-1.el6 will be installed
—> Package ed.x86_64 0:1.1-3.3.el6 will be installed
—> Package libresample.x86_64 0:0.1.3-11_centos6 will be updated
–> Processing Dependency: libresample.so.1.0()(64bit) for package: asterisk18-core-1.8.23.1-24_centos6.x86_64
—> Package pkcs11-helper.x86_64 0:1.07-5.el6 will be installed
—> Package python-inotify.noarch 0:0.9.1-1.el6 will be installed
–> Finished Dependency Resolution
Error: Package: asterisk18-core-1.8.23.1-24_centos6.x86_64 (@pbx)
Requires: libresample.so.1.0()(64bit)
Removing: libresample-0.1.3-11_centos6.x86_64 (@anaconda-CentOS-201303020151.x86_64/6.4)
libresample.so.1.0()(64bit)
Updated By: libresample-0.1.3-12.el6.x86_64 (epel)
Not found
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), ‘yum check’ output follows:
kmod-dahdi-linux-2.7.0-45_centos6.2.6.32_358.14.1.el6.x86_64.x86_64 is a duplicate with kmod-dahdi-linux-2.7.0-43_centos6.2.6.32_358.0.1.el6.x86_64.x86_64


#2

What kind of system, you need to be more specific. If this is a FreePBX distro, read the wiki on updates, not supposed to use yum.


#3

Any resolution? I was able to remove the duplicate package but the dependency conflict seems to have yum up a creek without a paddle. To change I have to remove all of asterisk.

—> Package asterisk-sounds-core-en.noarch 0:1.4.24-1.el6 will be installed
—> Package libresample.x86_64 0:0.1.3-11_centos6 will be updated
–> Processing Dependency: libresample.so.1.0()(64bit) for package: asterisk11-core-11.7.0-24_centos6.x86_64
–> Finished Dependency Resolution
Error: Package: asterisk11-core-11.7.0-24_centos6.x86_64 (pbx)
Requires: libresample.so.1.0()(64bit)
Removing: libresample-0.1.3-11_centos6.x86_64 (@anaconda-CentOS-201303020151.x86_64/6.4)
libresample.so.1.0()(64bit)
Updated By: libresample-0.1.3-12.el6.x86_64 (epel)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

FreePBX Distro version 4.211.64-5. I assume the OP has the same version, judging by the identical error.


#4

The upgrade procedure appears to resolve it:

http://wiki.freepbx.org/display/FD/FreePBX-Distro-4.211.64


(Tony Lewis) #5

Yes that is why we publish upgrade scripts. To take all the guess work and frustration out of upgrading. Glad they worked for you.


#6

I believe it is standard operating procedure to not require an upgrade script. That’s what yum is for. I don’t have to download an upgrade script for minor revisions of CentOS, yum takes care of it. In this case, yum was broken.

Tldr: yum alone should be sufficient to move between at least minor revisions of any distro.


#7

You added the epel repo all on your own, the update script removed it, yum will manage your updates but it is up to you to to know how to resolve dependencies if in your deployment various repos each claim different resolutions. Caveate implimentor.


(Tony Lewis) #8

Yes the point to the ugprade scripts are to fix things. Also yum can not handle the upgrade of FreePBX related items or fixing files and what not. Remember in CentOS case its just core packages. In the case of FreePBX its a complete Appliance built on top of CentOS. Hence why we have upgrade scripts.

And as you will see the upgrade scripts include using yum commands to update CentOS. It just wraps everything together to make sure they are timed correct.


(system) closed #9