You have 1 tampered files after warm spare import

Anyone else doing the warm spare backup getting a tampered file security warning?

I have tried to set up the warm spare settings on a couple of systems and am getting:
Module: “FreePBX Framework”, File: “/var/lib/asterisk/bin/retrieve_conf altered”

Am I doing something wrong? This issue shows up on the warm spare system, not the primary. The data import seems to have worked in both cases though.

1 Like

Nobody is seeing this? I set up a different set of systems and that warm spare is doing the same thing. I see a big red “Security Warning” banner across the dashboard of the warm spare after the data import.
Module: “FreePBX Framework”, File: “/var/lib/asterisk/bin/fwconsole altered”
Module: “FreePBX Framework”, File: “/var/lib/asterisk/bin/retrieve_conf altered”

Re-download framework.

Do I do that through the module admin? I don’t see a way to do that. Action only has one option “no action”. I’m wondering if this is going to keep happening and I’ll need to download framework every time?

fwconsole ma downloadinstall framework
fwconsole reload

Run this on both servers, and try again running a backup.

1 Like

Wow, that seemed to work and errors are gone. Thank you! I ran the warm spare backup job and it seemed to complete with no errors. I take it then the framework versions have to match?

When you do updates, update both servers at the same time.

Or at least do the backup first and if it works fine, update the primary before the backup job runs.

I can’t thank you enough. This has been a pain for me for a while now. Cheers!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.