Yealink T48 and Endpoint Manager

I’m having trouble with the Endpoint Manager provisioning a Yealink T48G.

I cant get it to push the template changes to the phone. It says its updating configuration but after it finishes nothing has changed on the screen. I of course can do it manually through the phones web interface but I want to use the Endpoint Manager.

If I Tail the logs for TFTP it shows that the phone is asking for mac.boot which it of course responds file not found since freepbx makes mac.cfg files. It never asks for a mac.cfg file.

I have tried different firmware versions old and brand new with no different results. I believe other Yealink models work just not this one. Could this phone have been altered by the previous owner for a particular provider?


I verified that all the other models of Yealink phones I have provision correctly. Its just this one T48G that wont and I don’t have another one to test. Has anyone else had success with the T48 phones? I am thinking there is something modified in this phone.

i had this problem on a T48S after update to the latest firmware. The config update did not work instandly. Sometimes it has taken up ton30 minutes. But the apache log showed up that the config file was taken directly after the phone bootet up.
Another customer had this issue because the LE certificate did not auto update anymore and was not valid anymore.

Thanks for the reply. I had put in a support ticket with Yealink and they got back to me.

If you have a Yealink that is looking for a .boot file you need to create a mac.boot file to put on your tftp with this in it.

## The header above must appear as-is in the first line
include:config <t> 
overwrite_mode = 1

It will then grab the correct .cfg file and off you go.

1 Like

That sounds like something the commercial EPM would like to handle. Have you submitted a ticket the “Issues” tab at the top of the page with the particulars?

You should not have to do that. The phones are suppose to request that file and if not their request the .cfg file. This is how all their phones have always worked before.

My config files have been taken but the update of the config happened about 30 minutes later. With old firmware all worked

I am experiencing the exact same issue with the Yealink T48G. Running FreePBX Endpoint manger is not working, even when manually put the tftp server in the Yealink settings.

Is the tftp service running?

I assume so, but what is the command to check? Thank you.

The phone keeps on saying “Update skipped!”

I solved my problem by running:
systemctl enable tftp
systemctl start tftp

But I’m surprised its not enabled by default. This is a proper Sangoma FreePBX ISO (upgraded from v13 to v14).
I wonder what other services that should be running, but are not.

TFTP is not secure and why we don’t enable it by default.