XMPP Daemon Problems

I cant seem to keep XMPP Daemon running. Every time I go into Dashboard its down.

When I tried to search for info. I find some entries from several years ago. and the Repeated solution is.

pm2 v13.0.3.3

Well, not sure what kind of instructions that is. I thought it may be one of the other module’s but not sure which one. and since the solution is from 3 to 4 years ago, i figure all updates are done past that version anyway.


I am afraid to try the upgrade to 14 since I tried to install 14 some time ago when it was first being posted. It just will not run on my system. Cant seem to find a list of system requirements anywhere and find it to be a touchy, unanswered subject if I ask.
So this time, I wont ask. I’ll just try to see if anyone can help with current XMPP issue?


Is XMPP upto date?

Don’t remember, but I think it’s

fwconsole xmpp start

Thanks for taking time to reply.

Yes, as far as I can tell, everything on it is up to date. I check online mods and nothing that can be updated shows up.
It shows XMPP to be at

If I try the fwconsole xmpp start, i get a red box error,
Command “xmpp” is not defined.

It’s fwconsole restart xmpp.

Also FreePBX 13 is only getting major bug fixes or security updates. I suggest you move on to the supported FreePBX 14 version.

1 Like

I would love to, as I stated above. However, when I tried to install it in the past. it wouldnt run on this box. I dont know why. its been a while. I just know that I end up having to go back and redo it to 13 and hand setting up all over again, couple of hours of work to set back up and get phones back.

Again, I cant find any detail about system requirements, so I dont know what I need to upgrade in order to move on.

I Knew that it was security updates only. but was going to live with it for some time so I dont have to go over invest in a PC because I dont know what spec’s is needed.
it seems to be a touchy subject if you ask.

It should work on any hardware that is 64 bit and 4GB of memory. We don’t publish info on specific hardware as it’s just RHEL 7 based ISO so anything RHEL supports we would support.

Thanks for this info, i’ll have to do some research and see if it meets requirements, if not, i guess i’ll have to hold on till i find a box that can.

Force dowload and install xmpp
Admin > Module Admin > Check online

XMPP > Force dowload and install…

1 Like

Thank you very much MTBT. that seems to have it resolved for now . even after reboot it stayed.

Very Grateful!!


Well, that lasted 3 weeks, and its out again, but i’ll do it again, thats better than it having to be worked with at every reboot,

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.