Xlite config converted to FreePBX

Hi all,

If I wanted to mirror this working config on X-Lite in to FreePBX, what would my config be?

FreePBX 13.0.192.19

Thanks,
Stroller10

Not sure I understand exactly what you’re asking for but, I’m assuming you’re asking how to configure FreePBX so that your posted Xlite config will work without changing any settings on the soft phone?

If so…
Create a new extension:
Extension Number: 043058370
Password: Same password as current Xlite config

Then…
PBX URL: Create a DNS A record for sip.freedom1.com that points to the public IP of your PBX (assuming you own the domain name freedom1.com)

Your Xlite config for your proxy address is probably going to have to change since 87.52.109.38 belongs to the current platform that you connect to I would imagine. You can just replace that with the FQDN of your PBX that you created as I mentioned above.

Apologies for not being clear.

The Xlite config are the details from my VSP. I want to move off Xlite and move to a hard phone via FreePBX.

So looking to find out what my trunk configuration and registration string should be?

Is there enough information above to move to FreePBX or will I need to contact my VSP?

Trunk registration is completely dependent on your provider that you choose.

Your Xlite settings are just connecting to another VPS server somewhere that is running PBX software that has a trunk configuration built out to a provider.

You need to start with a fresh install of FreePBX Distro and create your trunks from there, but as I said, trunk configuration is dependent on the provider you choose.

Some authenticate with username and passwords, some authenticate by IP, etc.

Ok thank you for the info.

The below are the details (altered by me) my VSP has instructed me to use however for “type” I don’t see any documentation so I don’t see how this config could ever work!?

user= 043058370
type=user authenticated
Password=XXXXXXX
host=87.52.109.38
fromdomain= sip.freedom1.com

Try something like this in the PEER details section when creating a SIP trunk:

type=peer
insecure=very
host=87.52.109.38
fromdomain=sip.freedom1.com
username=043058370
secret=YOURPASSWORD
dtmfmode=rfc2833
context=from-pstn
disallow=all
allow=ulaw,g729
qualify=yes

This should work, but ultimately your provider should be able to provide you guidance on how your trunk setup should be configured. A registration string may or may not be required, again, depends on your provider.

https://wiki.freepbx.org/display/FPG/Trunk+Sample+Configurations

1 Like

A registration string will be required. A generic string you can try is this format:

user:[email protected]:port
1 Like

Thank you guys, that worked to an extent. Outgoing works but incoming does not.

Outgoing is status OK
Incoming is status OK
Register String is State Registered

I see no INVITE in my debug when I attempt an incoming call?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.