Xen... rtc/ztdummy... Im ticked

Well… After researching it and finding sooo many people running Xen based Asterisk, I purchased a nice quad-core server w/ 4gb ram to serve as a host for our virtual mail/web/asterisk/backup server. Only to run into little problems with conferencing and DISA, and possibly the source of some occasional “static” on my voip lines. Come to find out that you NEED ztdummy and a rtc source to make em work right.

Currently im running a paravirtualized CentOS 5 system for asterisk. Is there any alternative clocking source I can use? Maybe throw in the zaptel card I have laying around and bridge it to the guest OS?

What about running fully virtualized? I can do that on a core2quad. Will I be able to use rtc.ko and ztdummy.ko in that environment?

I know this is more of a Xen question, but it seems to relate directly to Asterisk. Any takers?

I know nothing of Xen, but you can use an unpoppulated TDM400 as a very good clock source…

  • J

Xen or XENsource???

I started a XENsource project but had a HDD fail and never got back to it.

The host must be setup for ZAP / ZTdummy then you must give the guest OS access to the dev/zap

OpenVZ is the “easy one” something like this for OpenVZ

for x in ls /dev/zap; do /usr/sbin/vzctl set 200 --devnodes zap/${x}:rw --save; done


OK, I changed ztdummy to not look at RTC at all, so it should be using jiffies. zttest was BAD, 20-60% accuracy.
So I just recompiled the kernel to make the kernel HZ=1000. ztttest is between 93 and 99% accurate now.

What kind of accuracy should I be looking for? Conferences still just bomb out right after I enter the admin password.

Im just assuming that timing is the problem, but is there something else I should be looking for in Asterisk 1.4/Freepbx 2.3? Do conferences not work right?

Scratch that.

I recompiled asterisk and asterisk-addons against the updated zaptel and it works like a champ!

zttest accuracy is up to 98-99%. I might still take the TDM card and try to bridge it to the guest OS.

So… If you wanna use XEN, recompile the guest kernel with timing at 1000 instead of 250, and comment out:

/*#if defined(i386) || defined(x86_64)
#define USE_RTC
#if 0
#define USE_RTC

In ztdummy.c

Conferences work and DISA works now… And hopefully itll clear up the occasional static I get on my IAX2 trunks!

How does it do with more than one conference with MOH???
IAX trunking sound good ???


Well, I wasnt even in the office today, so I just called into it with my cell phone and setup Xlite on my laptop to get into a conference. Also had a customer call in which was forwarded to my cell phone at the same time… So that was 4 IAX lines in use at once using 711u and it sounded good… I left the conference connected for 1/2 hour kinda playing a CD through my phone and it sounded fine. Ill know for sure next week when I have someone in the office taking SIP calls while me and my biz partner are getting calls forwarded to our cell phones.

The server isnt even in our office actually, its a a co-location because most of our calls will be forwarded to cell phones and chances are, only 1-2 lines will be used in the office at a time. So static on forwarded IAX channels wasnt gonna work.

I left zttest running for quite a while earlier and it averaged 99.3% Had a low of 80, but I dont expect it to be 100% as accurate as a dedicated clocking source.

If I have problems, ill put the TDM card in and bridge it over to the DomU and see how it works.

RE: Load… I didnt even answer your question fully… .Are you referring to # of channels in use, or system load… Because the computer is really overkill, so system load isnt going to be a problem… I was compiling another program on another DomU and on the Dom0 at the same time and it was fine…

Yeah… it was still not right with DISA and conferences… I put the TDM card in and bridged it over to the DomU and I get flat 100% timing on zttest now. Well see how it performs!

I was hoping to get some specific information on how to compile the zaptel drivers in a centos xensource VM. I’m having troubles currently with a ‘version magic’ error when trying to run the compiled modules. I’ve written it out in detail here:


It looks like you found a way to get zaptel up and running, I’d love to hear what you did!