x100p clone card (from x100p.com) and dahdi?

Hi all :slight_smile:

Apologies in advance for dumb noob questions and lack of info… I’m totally new to the linux/asterisk/freepbx world.

I have an old dell pc (256mb RAM, 20gb HDD, P3 processor) on which I have installed the latest version of asteriskNOW 32 bit and freePBX 2.8.0.2.

I want to use this as a home & small business PBX with one incoming legacy POTS line and potentially 2 or more SIP trunks in the future.

My first task was to get the system up and running with the existing POTS line… and I seem to be failing dismally !! :frowning:

Installed in the PC is an x100p clone card sourced via x100p.com. This is connected direct to an Irish (Eircom) POTS line. I have a standare analog handset connected to the bypass port on the card. The system is seeing the card and it is being detected OK via freepbx.

I have also installed x-lite on a windows xp machine as my sip client, and this seems to be connecting to and seeing the asterisk box. However the extension does not ring when I make a call to the POTS number (the analog phone connect to the bypass port on the card does ring , and if I try to call out, I get “The person you are calling is unavailable, please try again”.

The various settings that I think might be relevant are detailed below as best I can. I have search the forums and user sites, but any support/help/forum info on the problem that I find seems to relate to ZAP config rather than DAHDi and I’m guessing that this problem may not arise much any more as most people still using fxo cards seem to have 4 port cards now.

Thnaks in advance for any help/advice on how I can move forward.

Japnuts.

Dahdi Settings:

Analog FXO Ports

Port 1:Loop start Group:0 Context:from-pstn

Advanced Settings

Module Name:wctdm24xxp
Tone Region:United Kingdom
Opermode:(enabled) TBR21
A-law Override:(enabled) Alaw
FXS Honor Mode:(not-enabled)Apply opermode to FXO modules
Boostringer:(not-enabled)normal
Fastringer:(not-enabled)normal
Lowpower:(not-enabled)normal
Ring Detect:(not-enabled)standard
MWI Mode:(not-enabled)none

Extensions

Display Name Conservatory
CID Num Alias (Blank)
SIP Alias (Blank)

Extension Options

Outbound CID (Blank)
Ring Time Default
Call Waiting Enable
Call Screening Disable
Pinless Dialing Disable
Emergency CID (Blank)

Assigned DID/CID

DID Description (Blank)
Add Inbound DID (Blank)
Add Inbound CID (Blank)
Any DID (Eircom POTS)

Device Options

This device uses sip technology.
secret ********
dtmfmode rfc2833
canreinvite no
context from-internal
host dynamic
type friend
nat yes
port 5060
qualify yes
callgroup (Blank)
pickupgroup (Blank)
disallow (Blank)
allow (Blank)
dial SIP/1001
accountcode (Blank)
mailbox [email protected]
vmexten (Blank)
deny 0.0.0.0/0.0.0.0
permit 0.0.0.0/0.0.0.0

Recording Options

Record Incoming on-demand
Record Outgoing on-demand

Voicemail & Directory

Status disabled
Voicemail Password
Email Address
Pager Email Address
Email Attachment yes no
Play CID yes no
Play Envelope yes no
Delete Voicemail yes no
IMAP Username
IMAP Password
VM Options
VM Context
VmX Locater

VmX Locater™ Disabled
Use When: unavailable busy
Voicemail Instructions: Standard voicemail prompts.

Press 0: Go To Operator
Press 1:
Press 2:

Route Settings

Route Name:LocalEircom
Route CID:(Blank) Override Extension (disabled)
Route Password:(Blank)
Route Type: Emergency (disabled) Intra-Company (disabled)
Music On Hold? default
Route Position --No Change–
Dial Patterns that will use this Route

() +9 | [. / ]
() + | [ / ]

Dial patterns wizards:
Trunk Sequence for Matched Routes

0 g0
1

Trunks

Trunk g0

In use by 1 route
General Settings

Trunk Name:g0
Outbound Caller ID:(eircom phone number) *********
CID Options:allow any CID
Maximum Channels:1
Disable Trunk:(blank) Disable
Monitor Trunk Failures:(blank) Enable

Dialed Number Manipulation Rules

() +9 |.
() + |

Dial Rules Wizards:(pick one)
Outbound Dial Prefix:w

Outgoing Settings

DAHDI Identifier:1

Inbound Routes

Incoming Route

Description:Eircom POTS
DID Number:(Blank)
Caller ID Number:(Blank)
CID Priority Route:(Blank)

Options

Alert Info:(Blank)
CID name prefix:(Blank)
Music On Hold:default
Signal RINGING:(Blank)
Pause Before Answer:(Blank)

Privacy

Privacy Manager:No

Set Destination

Extensions <1001> Conservatory

DAHDI does not support x100P

Hi,
You can buy a 4 channel card for test.

Try Elastix or PIAF they still give you the option to use zap over dahdi.

Here is what I did to get my X100p clone card (ebay for 20 bucks) working on FreePBX with PBX in a Flash (PIAF-Nerdvittles version Dec 2011).

  1. Get PiaF installed with FreePBX

  2. Setup the correct module to: wcfxo
    (look under FreePBX-Setup-DAHDI-Advanced Settings-Module Name: wcfxo)

  3. Shut down and install x100P card in a vacant PCI slot (I tried 2 different slots and both worked fine).

  4. Boot up and look at the dmsg log (logon to Webmin, System, System Logs, Output from dmesg, and look to see if dahdi found a Wildcard FXO: Generic Clone.

  5. Go to FreePBX, Trunks, Add DAHDI trunk. I used:
    Trunk Name: ZAP/g0
    Outbound Caller ID: 9705551212
    Maximum Channels: 1
    didn’t change/add anything in the "Dialed Number Manipulation Rules"
    Outgoing Settings: DAHDI Trunks: menu select: Analog Channel 1
    Save/Submit, Save, Apply.
    Note: I did select “configure/edit DAHDI cards” (analog card edit)
    and changed the info to Context: from-zaptel

  6. Connect phone company line to the LINE port on x100P card. Connect a spare phone to the PHONE port on x100P card

  7. Setup incoming and outgoing routes to use the trunk.

Note: the caller ID was screwed up on my phoneline. So I left the “DID number:” and “Caller ID Number:” fields blank. I did set a destination (extension, voicemail). This is the only incoming line that is blank for DID/Caller ID. This allowed Asterisk to answer the line.

For Outgoing, I didn’t do anything special except specify ZAP/g0 in the “Trunk Sequence for Matched Routes”. I use a 5 to get an external POTS line thru this setup so I had to set the outbound rules PREFIX to 5.

I have to hand it to you rkaczano. I have been losing sleep over how to get this app functioning properly with my X100P. I have visited so many forums and although the community members were very patient and willing to assist, the replies always seemed to contain comments on how “crappy” the X100P was. I was also told on more than one occasion that it was no longer supported.

Your instructions helped me immensely, and now I can get a good nites sleep, finally!

I am just getting started and do not have the means to invest in an expensive card. So the X100P is the best that it is going to get for the time being. Have a wonderful day, now I know that I will.

Peter

Well, I suppose that I spoke too soon. After following the great instructions provided by rkaczano, I managed to make and receive calls via X-Lite softphone. What I did next was too perform a fresh install of PIAF. Followed the same instructions, but all I get now is the dreaded “All circuits are busy” message. I am not able to receive calls either. Back to the drawing board as the old saying goes.

My card stopped working a few days after install… I decided to upgrade to PiaF/Nerdvitles Incredible PBX 3.0… so here is how I got my X100p clone card working. (on x86 w/ 32bit version of CentOS)

  1. Install the card in a PCI slot
  2. Download and install the NerdVittles/PiaF/Incredible 3.0 from this post: http://nerdvittles.com/?p=795 (this will install CentOS 6.2 and PiaF and FreePBX and some other Nerdvittles scripts that are awesome).
  3. Then I followed these old instructions: http://www.cadvision.com/blanchas/Asterisk/DahdiPOTSlineTrunk.html (I configured everything thru FreePBX)
    (The instructions are good, just old screenshots… but the meat & potatoes are there (I used the add ZAP trunk (dahdi compatible), not “add DAHDI” trunk.)
    I did make one change on the FreePBX config, Setup-DAHDI-edit the FXO card and put in “from-zaptel” in the CONTEXT: field.
  4. When everything was configured thru FreePBX, I restarted the machine (shutdown -r now)
  5. When it was booted up and all services are running, I made a test call from X-lite and it worked!!!
    It’s been running fine for 2 days now… hopefully that’s the end of the X100p problems and I can retire my old IP-PBX02 from atcom (works fine, but not much room for additional apps) I also configured outbound route to use “4” to use the PSTN line, not a 9 like the example-works fine either way.

Oh yeah,
Make sure edit the wcfxo setting… SETUP-DAHDI-Advanced and change the “Module Name” to: wcfxo (set to the appropriate module for your card…if X100p, then should be: wcfxo)

And some instructions say to use g0 in the “Add ZAP trunk” for the “ZAP identifier”, I used “1”. I think this refers to the same setting in the /etc/dahdi/system.conf where fxsks=1

/etc/dahdi/system.conf

Span 1: WCFXO/0 “Generic Clone Board 1” (MASTER) RED

fxsks=1
echocanceller=mg2,1

g0 is group zero, just put the single integer of the DAHDI chanell

It is amazing the level of effort you guys are expending to get this P.O.S. single port trunk card working.