X-ClientCode and useclientcode=yes with freepbx

Hej Folks!

I am trying to get AOC-Information into the “userfield” of CDR-Records. I know my berofix – box is transmitting the information (traced it), I also know elastix is receiving the X-ClientCode – Header (sip set debug on…), I enabled “useclientcode=yes” in sip.conf. BUT: I get nothing in the CDR’s.

My System: elastix 2.x current with freePBX 2.8 current. The berofix ISDN – Gateway is equipped with a custom firmware to transmit aoc-information in SIP – headers.

Any idea about what I might be missing?

Thanks for your support,

I’m not familiar with it.

According to voip-info.org:

useclientcode = yes|no : If yes, then the Call Originator as stated in the CDR will be changed to whatever is specified in a X-ClientCode SIP Header. Default no. (New in v1.2.x)

doesn’t look like it has anything to do with the userfield in the CDR.

Also, according to the Asterisk sip.conf sample file, this looks like a peer setting, not a general setting, so make sure that it is being set with the peer. (May need to do it in the ‘post’ conf file with peer_num notation.