Wrong IP on incoming calls

Hello all…

I have a server with a static IP, we’ll say its I have a provider that sends calls from IP or The problem I’m having is that all incoming calls (even from sip scanners from palestine trying to hack me) all show up as coming from

-- Executing [[email protected]:1] NoOp("SIP/", "Received incoming SIP connection from unknown peer to +1917XXXXXXX") in new stack -- Executing [[email protected]:2] Set("SIP/", "DID=+1917XXXXXXX") in new stack -- Executing [[email protected]:3] Goto("SIP/", "s,1") in new stack -- Goto (from-sip-external,s,1) -- Executing [[email protected]:1] GotoIf("SIP/", "0?checklang:noanonymous") in new stack -- Goto (from-sip-external,s,5) -- Executing [[email protected]:5] Set("SIP/", "TIMEOUT(absolute)=15") in new stack Channel will hangup at 2013-09-26 09:14:53.283 PDT. -- Executing [[email protected]:6] Log("SIP/", "WARNING,"Rejecting unknown SIP connection from"") in new stack

Yes and yes. I am able to receive and place calls just fine, as long as allow anonymous calls is set to yes.

More info please. You have provided absolutly no info on how your system is installed or configured. How it is connected to the internet? We can’t help if you don’t provide detailed information.

What would you like to know?

I have a business internet account with Cox cable, using a cisco dpc3010 modem. From there it goes to a dlink dir-655 router, and then straight to the asterisk box. I pay for a static ip and have no port blockings.

What else could I provide?


Do you have the correct ports forwarded to your PBX? Are the internal and external IP addresses configured in FreePBX?

With sip debugging, I can see the real address ( come into asterisk, but its getting translated to for some reason…

Sending to (NAT) Using INVITE request as basis request - [email protected] No matching peer for '+1917XXXXXXX' from ''

ip config from sip settings

External IP?
Local Networks?

What is in your localnet settings?