Wrong from: address in sent emails

I’m trying to get FreePBX to send emails. Right now, all emails sent out show the From: address
as [email protected]
This from: field gets rejected by my mail server with a 450 error.

I have worked on /etc/hosts and /etc/networks and now when I do :
mail -s “test from PBX” [email protected]

the From: field shows as :
[email protected]

Which works correctly. But, for some reason, FreePBX does not pick up those defaults.
Can somebody tell me what file needs to be checked to fix this?
I am running the latest FreePBX, just updated last week: 13.0.167



Look under advanced settings there a option in there for the from address