Won't stay connected

Good day all,

I have installed the latest disto (1.813.210.58) and am able to get everything working; however, everything stops working after a while. Here’s some info that will hopefully help get us on track:

I’m using a Charter phone line setup with a DAHDI trunk.

I have a TDM400P card that I got on eBay

The TDM400P has 2 FXO and 2 FXS. I’m using port 1 for the PSTN, I’m trying to use port 3 for a traditional phone I was using prior to attempting my own PBX.

Something weird that happens is when I connect my traditional phone to the FXS port it seems crash sooner. Don’t know if this is a separate issue or if it’s related to this issue.

I’ve tried the configuration on 3 separate machines with the same results.

I’ve tried using the latest AsteriskNOW distro, same results. Actually, I started there and figured I’d go straight to the FreePBX source thinking is was the version Asterisk was using.

When the problem happens I can’t connect to the FreePBX admin site via the IP address. I have to reboot the system to get everything back up.

I’ve done what little I know how to do to check the DAHDI connection, and all checks out. Leads me to think it’s network related, since I can’t get to the admin panel.

I am an owner/operator of an IT consulting business in my area, so I have lots of networking and computer experience; however, my Linux knowledge is very limited, as is my telco experience.

Sorry for the sporadic explanation, I have a lot of variables and don’t know which ones are important, so I threw them all up here.

Thank you all for any help you can provide.

I don’t think there is any direct relationship between thedahdi Software and the network per se, Asterisk knows about both, but to it, dahdi is just a channel driver (and secondarily a timing source sometimes :slight_smile: ).

There are some hooks in to the kernel for clock and stuff, so maybe there is a hardware problem with the TDM400 (that is a real Digium, right?), do your network based phones have a problem f you remove the dahdi hardware?

Thanks for the reply. I’ve been digging on this issue for days, and it’s hard to know where to start.

No, I don’t think this card is a real Digium, and is probably the culprit to to my issues. When testing before I got the TDM card I don’t remember experiencing any issues. I can try removing it for a day or so and see if internal phones stay working.

The TDM card is the ONLY common variable that persists between the 3 systems I’ve tried this on, so it sounds like I may be hunting for a new card. I just wanted to weed out any other variables before dropping $$ on a new card. Can you think of any other things to try?

Not until you verify that your hardware is not an illegitimate copy of a legitimate product. If legitimate I have always found Digium to be slow but rigorous in their support. All I can say is"Caveate Implementor", you get what you pay for :wink:

Yup, agreed. I just ordered a REAL Digium card… Thanks for your help.

Just a followup for future readers that may be experiencing these types of issues:

My authentic Digium card seems to have done the trick. I’ve been live and running seamlessly for 48 hours.

Don’t “save money” by buying a knock off card. You will spend less by buying the real thing!