WMI delay for Linksys/Sisco SPA942


(Frankyboy) #1

Hello, first sorry for my poor english. I have a newbie question.

I am a new user of FreePBX which I love. We have an internal server with the latest free version of Sangoma FreePBX. I have configured our old Linksys (now Cisco) model SPA942 brand phones and everything has been working fine so far except for a small bug. When a voice message arrives in the box, the lamp indicating the presence of message (WMI) suffers from a delay of up to 1 hour, which in my opinion corresponds to the moment when the phone will re-register with the server. Same thing when we delete the message. I have been able to work around the issue by forcing the phones registration expiration to 20 seconds instead of 3600 (see creenshot). I know this is probably not the best solution, but so far everything seems to be working fine.

Do you have any possible solutions to suggest to me to resolve this type of problem? Do you think that forcing phones to reregister in such a short time can bring problems?

Thanks in advance for your help!


(Lorne Gaetz) #2

In Settings -> Voicemail Admin -> Settings tab -> General tab. What do you have set for poll mailboxes and poll frequency? If not enabled, set to yes with a poll interval of 10 seconds, see if that fixes. If using PJSIP extensions, then check the MWI Subscription Type, you might get different behavior by changing from Auto.


(Frankyboy) #3

Hi Igaetz and thank you for your help.

Poll Frequency is already set at 10, and poll mailboxes already set to YES. Im set in SIP (not PJSIP)

Any other thing I can check?


#4

I’d say a registration expiration time of 20 seconds is lower than usual. Having said that, it is commonly required to decrease a default value of 1hour/3600sec for some networks. This is usually necessary when the phones are behind a different NAT, and the nat tunnel closes when there’s not enough traffic to keep the connection alive, leading to unreceived calls, or in your case MWI notifications. Lowering the expiration interval to 2 minutes usually helps from what I’ve seen. I can’t say for sure that 20 seconds would cause any harm beyond the extra traffic, but maybe try a setting like 2min to see how that goes. Are the phones having the issue on a different network than the pbx?


(system) closed #5

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.