I just purchased a Linksys WIP300 phone. I was able to get it to successfully register, it can make internal and outgoing calls, however When dialing it’s extention from another phone it eventually stops responding and the call goes to voicemail.

It seems if I then make a call from the WIP300 it once again then responds to incomming calls and correctly rings for a few minutes.

The Asterisk/FreePBX is hosted externally with a public IP at my datacenter the WIP300 is at my house house NATted behind a linksysG router. I have a proxy server setting on the phone and the extention profile in FreePBX is set for NAT.

I also tried using a STUN server but that did not help.

Any ideas would be greatly appreciated.

try setting qualify=yes on the extension. It will make it more visible if the extension goes down. Also, the regular ‘pings’ that are sent to keep the qualify information up-to-date may help to keep any nat connections open. Or - it the WIP300 has any sort of ‘keep-alive’ settings, turn those on.

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

Originally I did try qualify=yes, it did not seem to work. There does not seem to be a keep a alive function function. I just tried setting the register time out value to 36 as opposed to the default 3600 and this does seems to work most of the time. It looks like either a bug in the phone’s software or maybe an issue inherent to running SIP over a wireless connection.

I don’t really understand the qualify setting but I’ll go back and try again?

Thank you for your suggestions

setting the registration down is one way to overcome the lack of a keep-alive. This was common for Polycom phones before they introduced a keep-alive feature. The issue is that the UDP session in your home router is not staying open so Asterisk can’t contact you. The UDP session length is very small since there is really no such things as a udp session. So typically in the range of 30-60 seconds for most routers. One way around this would be to pick a different configuration port than 5060 for you phone. Set it up accordingly on your FreePBX config. Then port forward that port (e.g. 5064 for instance) to your phone from your router. You wouldn’t want to do this with the default 5060 port because there may be other clients in your house (not phones) that depend on SIP as well, unrelated to your PBX functions. This could mess them up potentially.

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

Finally an explanation that makes sense. When I have a chance I will experiment with another port and port forwarding as you suggested. Currently with my kludge (short SIP register time) it seems to be working acceptably but not elegantly.

I am surprised there is not a lot of web chatter about this problem.

Thanks again.

Hi, Phodara1,
I need any help with WIP300 phone. I buy a WIP300 unit to use it as extension in Asterisk Freepbx system.

I could setup it fine and phone registered propertly with PBX, but when i make a call phone display show “Unknown” and call drops.

Any idea or suggestion?

The only settep parameter that is setup different from an stadard configuration of Freepbx, is that SIP port in my PBX is diferent from 5060; but i settup WIP300 with this diferente port and it can register propertly.

Thanks in advance!