Wierd behavior with Digium phone


#1

Hello,

Using

FreePBX 15.0.17.34
EndPoint Manager 15.0.39.62
DPMA 3.6.3
Digium D40 phone with firmware 2_9_12

I have a phone in my home office.

Today, I can’t make phone calls anymore.

When I dial, it doesn’t do anything for a few seconds, then it does the “busy sound”.

I tried rebooting it, restoring it to factory default, everything… it still won’t work.

The weirdest thing is that I can RECEIVE calls, just can’t make any outgoing call.

I tried looking what’s going on in the asterisk CLI… I can see a lot of things when there’s an incoming call for this extension.
But when I try to make an outgoing call… NOTHING!

So I figured it might be a firewall issue?
My IP was not in the ban list of Intrusion Detection…
Nonetheless, I completely disabled the firewall to test.
Still nothing.

Dial pattern is
[0-8]xxxxx|911|9411|9611|9011xxx.T3|91xxxxxxxxxx|9[2-9]xxxxxx|*xx.T3|[0-8]xx.T3
Which appears fine to me.

This really puzzles me.

Any idea?


#2

So you could make calls out prior to today?
what country are you in? what number did you try to dial?


#3

Canada

Any number I try to dial will not go through

I tried my cellphone for example


#4

This dial pattern is set up for a system in North America that requires dialing 9 before an outside number. This is not the recommended way to set up a modern PBX, but some systems are done that way for compatibility with a legacy system they replaced.

If your PBX does not require (or permit) dialing 9 before an outside number, your phone has a corrupted dial plan (perhaps it got defaulted somehow).

Otherwise, try dialing these numbers:
*65 (reads back your extension number)
*43 (echo test)
918004377950 (should read your caller ID).
If your cell phone number is e.g. 212-345-6789, try dialing 912123456789.


#5

when you say “I tried my cell phone as an example” that doesn’t tell us anything, please include the EXACT number you dialed as you dialed it (obviating the last 4 digits with “xxxx” for privacy). It’s the only way to tell if it’s a dial string issue based on the dial strings you posted.

also try using this dial string:

1800NXXXXXX|1833NXXXXXX|1844NXXXXXX|1855NXXXXXX|1866NXXXXXX|1877NXXXXXX|1888NXXXXXX|1NXXNXXXXXX|211|311|411|511|611|711|NXXNXXXXXX|NXXXXXX|911|933