Why not DAHDI but ZAP?

I have installed the Asterisk 1.6.2 and FreePBX 2.6 RC2. I noticed the sample configuration file extension.conf are different. Original extension.conf file using dahdi for the PCI card I have, but the extension configuration file generated by the FreePBX using ZAP instead. Where could I fix this?

extensions.conf.sample:; in chan_dahdi.conf) to dial, i.e. group 2, and how to choose a channel to use
extensions.conf.sample:exten => s,n,Dial(dahdi/12) ; added this line and next by me
extensions.conf.sample:exten => 1,1,Dial(dahdi/8|60|m(default)) // zap has been changed to daidi
extensions.conf.sample:exten => 2,1,Dial(dahdi/6|60|m(default)) // zap has been changed to dahdi
[root asterisk]# grep ZAP extensions*
extensions_additional.conf:OUT_1 = ZAP/6
extensions_additional.conf:OUT_3 = ZAP/8
extensions_additional.conf:OUT_4 = ZAP/7
extensions_additional.conf:OUT_5 = ZAP/9
extensions_additional.conf:exten => 7010,hint,ZAP/2&Custom:DND7010
extensions_additional.conf:exten => 7015,hint,ZAP/1&Custom:DND7015
extensions_additional.conf:exten => 7082,hint,ZAP/3&Custom:DND7082
extensions_additional.conf:exten => 7138,hint,ZAP/4&Custom:DND7138

Because of that, I think, when I call from extension 7010 on DAHDI/2 to 7015 on DAHDI/1, it almost immediately go into voicemail. The full log file showed this:

[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: – Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: recordingcheck,20091002-130908,1254514143.3: Inbound recording not enabled
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: – <DAHDI/2-1>AGI Script recordingcheck completed, returning 0
[Oct 2 13:09:08] VERBOSE[5184] pbx.c: – Executing [[email protected]:5] MacroExit(“DAHDI/2-1”, “”) in new stack
[Oct 2 13:09:08] VERBOSE[5184] pbx.c: – Executing [[email protected]:9] Macro(“DAHDI/2-1”, “dial,15,tr,7015”) in new stack
[Oct 2 13:09:08] VERBOSE[5184] pbx.c: – Executing [[email protected]:1] GotoIf(“DAHDI/2-1”, “1?dial”) in new stack
[Oct 2 13:09:08] VERBOSE[5184] pbx.c: – Goto (macro-dial,s,3)
[Oct 2 13:09:08] VERBOSE[5184] pbx.c: – Executing [[email protected]:3] AGI(“DAHDI/2-1”, “dialparties.agi”) in new stack
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: – Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: dialparties.agi: Starting New Dialparties.agi
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: dialparties.agi: Caller ID name is ‘unknown’ number is ‘unknown’
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: dialparties.agi: Methodology of ring is ‘none’
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: – dialparties.agi: Added extension 7015 to extension map
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: – dialparties.agi: Extension 7015 cf is disabled
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: – dialparties.agi: Extension 7015 do not disturb is disabled
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: dialparties.agi: EXTENSION_STATE: 4 (UNAVAILABLE)
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: – dialparties.agi: DbDel CALLTRACE/7015 - Caller ID is not defined
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: – dialparties.agi: Filtered ARG3: 7015
[Oct 2 13:09:08] VERBOSE[5184] res_agi.c: – <DAHDI/2-1>AGI Script dialparties.agi completed, returning 0
[Oct 2 13:09:08] VERBOSE[5184] pbx.c: – Executing [[email protected]:7] Dial(“DAHDI/2-1”, “ZAP/1,15,tr”) in new stack
[Oct 2 13:09:08] WARNING[5184] channel.c: No channel type registered for ‘ZAP’
[Oct 2 13:09:08] WARNING[5184] app_dial.c: Unable to create channel of type ‘ZAP’ (cause 66 - Channel not implemented)
[Oct 2 13:09:08] VERBOSE[5184] app_dial.c: == Everyone is busy/congested at this time (1:0/0/1)
[Oct 2 13:09:08] VERBOSE[5184] pbx.c: – Executing [[email protected]:8] Set(“DAHDI/2-1”, “DIALSTATUS=CHANUNAVAIL”) in new stack

Why it is Dial(“DAHDI/2-1”, “ZAP/1,15,tr”) in new stack?