Why is Zulu Trash?

The latest “stable” release you download 3.0.2 I think it is? Automatically tells you there’s a new version of Zulu as soon as you launch, even though the app at that time is set to Stable. It then in turn downloads and installs the Alpha build. Which I can’t tell for sure if it’s an issue with the Alpha build or an issue with the stable. However

  1. Why is the app automatically making users upgrade to an Alpha build even though Stable is selected?
  2. The app refuses to remember credentials or URL information even though the save checkbox is checked.
  3. The app now refuses to show any type of device being connected for sound / ringing / mic. As soon as you initiate a call on Zulu it just hangs up the call.

Also the Outlook plugin functioned like trash and wouldn’t even dial anything.

Is it just me?

It’s on a Windows 10 Pro system and this is on 3 of them all have this issue

I understand your frustrations however it’s really not appropriate to just call it trash outright when It seems like you have very specific issues with Zulu which could be handled by just using support services. Have you tried going through support yet?

Specific issues? On three windows boxes with new installs your app makes them all update to the alpha version. This is on a clean install of Zulu.

The app so far all around has had a very buggy feel.

That’s why I’m asking if anyone else is having these issues. As it’s happened on three windows installs thus far. Why would the app force the user to install the alpha version even though stable is selected?

If I’m to guide an end user to download your product and just install it, it shouldn’t be advising them to install an alpha version which seems to be borked (won’t see audio devices, won’t make calls because of that and won’t save credentials.)

Then add to that when you “x” out of Zulu and the main window goes away as if Zulu has been closed. Is it minimizing the window to the system tray or is it actually closing Zulu. Because there’s no notice of what it’s doing. But if you try to launch Zulu again nothing appears. Instead you have to go to task manager and force quit what is now multiple instances of Zulu supposedly running even though there’s no main window open anymore.

So sure one bug I could get or an issue on a system. But on 3 systems and multiple issues with the software automatically telling my users to install an alpha version of the software that further breaks it = trash to me

But that’s what I’m trying to figure out is it a poorly coded app or something else? Has anyone else had these issues with a clean install on windows 10?

Are you honestly trying to get that answer or are you trying to trash talk software? If you want what you say you have issues with fixed wouldn’t you report it as a bug or inquire with support. Thats what it’s there for after all.

This topic could be worded in a far less hostile format. “Why is Zulu trash” and “poorly coded” are worded in a way that is sure to attract the attention of anyone at Sangoma. Instead it could have been worded such as “Zulu has a lot of bugs” or “anyone else having issues with Zulu”. Do you see the difference?

This is an open forum and I don’t want to stifle opinion but I won’t put up with hostile wording. Complaining about it is fine. You can think it’s terrible all you want and you can complain about your issues. But I’m not going to sit here and let you keep trash talking the software “why is Zulu trash” or the software team “poor coding” on out own forums when you have the tools at your disposal to answer the questions you have.

So you’ve got our attention. If you feel these are bugs then use the support tools at your disposal. From there a support person would be able to confirm your issue or get to the bottom of it.

If you want to continue this thread and get responses from others I’m going to ask you kindly to tone down your responses, to stop using hostile and accusatory language.

Thank you for your understanding.


When I have the tools at my disposal to answer my questions on my own? I’m not sure I didn’t code your software to update a stable release fresh install to alpha. Don’t you think this is an issue your coders should look into?

I think you’re taking this a bit personally and instead let’s figure out what’s making Zulu act like trash. Maybe when you have clients blowing up your phone because a paid Sangoma appliance (two of them we just deployed plus a freepbx virtual environment) all of which are using Zulu all of which are different systems have this issue.

So what’s going on and what’s your recommendation so they don’t call me yelling at me saying it’s trash and not working. I didn’t code the software you guys did

You are the only one to say this.

Edit: I originally asked the lead developer of the Zulu project to look into this and he originally couldn’t find the issue but then he just found that it is an issue. However this was after I brought it to his attention. If you would have opened a support ticket 20 hours ago this could have been fixed today

Ok, I have asked you to stop using that word three times and yet you continue. If you want to “figure out [the issues together]” then use support like I originally stated. Since you refuse to open any support tickets and you don’t want to listen to the warnings I’ve given this thread is over. I honestly do not think you want to cooperate otherwise you would have either stopped using that language or gone to support.

I gave you a recommendation twice. You’ve yet to follow it (I looked up your email in the support system, there are no tickets from you).

If you want your issues fixed then by all means support is open (and free) for your use but I am tired of telling you how to get this solved for you to not follow through and continue to do what I asked you (twice) not to do.

I’m closing this thread for two reasons:

  1. I asked you twice to stop using language like the word “trash”
  2. I told you twice where to go to get help. Support. The support system. No tickets have been opened.

Zulu discussion is fine but if you aren’t going to listen to what I am asking then there is no point in continuing this thread.