Whoops error on checking online for module upgrade

At some point after updates yesterday (new rev of php56 module via yum/system updates and a few new module updates via the traditional module updates, including a freepbx framework update), my web interface is returning a whoops error when checking online for module updates. When using the command line (fwconsole ma update all), I get the following:

PHP Fatal error: Class ‘Rhumsaa\Uuid\Uuid’ not found in /var/www/html/admin/libraries/modulefunctions.class.php on line 2661
Whoops\Exception\ErrorException: Class ‘Rhumsaa\Uuid\Uuid’ not found in file /var/www/html/admin/libraries/modulefunctions.class.php on line 2661
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/libraries/modulefunctions.class.php:2661

I am also getting incorrect info on the Asterisk info page (shows no trunks/extensions connected, etc) - but actual phone system functionality is intact (can make/receive internal calls, external calls, vm access, all OK.) UCP also seems OK.

I am running distro version 12.7.4-1712-2.sng7, freepbx version, asterisk version 15.1.5

Any thoughts on how to resolve? System was behaving properly before updates yesterday …

Oh, I also have the following error on my dashboard:

Cronmanager encountered 1 Errors

The following commands failed with the listed error
/var/lib/asterisk/bin/module_admin listonline > /dev/null 2>&1 (255)


wget https://raw.githubusercontent.com/FreePBX/framework/release/14.0/amp_conf/htdocs/admin/libraries/modulefunctions.class.php -O /var/www/html/admin/libraries/modulefunctions.class.php && fwconsole ma downloadinstall framework --edge

That mostly fixed me, but now I have a Security Warning:

"Module: “FreePBX Framework”, File: “/var/www/html/admin/libraries/Composer/vendor/bin/uuid altered”

I tried “fwconsole ma refreshsignatures” but that did not get rid of the issue …

upgrade framework

fwconsole ma upgrade framework


“framework is newer than online version, unable to upgrade”

Do it through the web browser

That fixed it. Thanks!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.